This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 221000 - qt-config menu entry is broken because qt-config binary isn't installed to the path
qt-config menu entry is broken because qt-config binary isn't installed to th...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: EasyFix, Patch
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2006-12-30 01:25 EST by vfiend
Modified: 2008-03-07 09:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 09:39:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for spec file (822 bytes, patch)
2008-03-06 11:00 EST, Michal Fabry
no flags Details | Diff

  None (edit)
Description vfiend 2006-12-30 01:25:05 EST
Description of problem: The .desktop file tries to run 'qtconfig' but that
binary isn't installed in the path so it won't launch.


Version-Release number of selected component (if applicable): qt-config 1:3.3.7-0.1


How reproducible: Always


Steps to Reproduce:
1. Install qt-config
2. Click System-Preferences-More Preferences-Qt3 Config
  
Actual results: "Could not launch menu item
Failed to execute child process "qtconfig" (No such file or directory)"

Expected results: qtconfig launches


Additional info: $ rpm -ql qt-config
/usr/lib64/qt-3.3/bin/qtconfig
/usr/share/applications/qtconfig3.desktop
/usr/share/pixmaps/qtconfig3.png

So the .desktop file needs to look in /usr/lib64/qt-3.3/bin/ for qtconfig or
qtconfig needs to be installed the path, I guess
Comment 1 vfiend 2007-05-03 05:16:09 EDT
Still a problem in F7 Test 4
Comment 2 Michael Sedkowski 2007-12-17 17:22:07 EST
The same thing in F8 with package version 3.3.8-9.
Comment 3 Lubomir Kundrak 2007-12-30 08:27:30 EST
Reported on a local mailing list. Raising priority and making a blocker -- this
is easy enough to be fixed in twenty seconds either by the maintainer himself,
or by permitting cvsextras commits.

https://www.redhat.com/archives/fedora-cs-list/2007-December/msg00005.html
Comment 4 Michal Fabry 2008-03-06 11:00:41 EST
Created attachment 297063 [details]
Patch for spec file

Patch which changes path in .desktop file for qtconfig.
Comment 5 Ngo Than 2008-03-07 09:39:23 EST
problem is that /usr/lib64/qt3/bin is not set in your PATH enviroment. If you 
install qt-devel on you machine, it will fix the problem. Your patch fixes the 
problem but causes multilib issue!

The problem is now fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.