Bug 221003 - [RFE] Allow more premiscous sharing
[RFE] Allow more premiscous sharing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2006-12-30 04:44 EST by Pierre Ossman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.7.74.2-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-21 13:47:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 2008 None None None Never

  None (edit)
Description Pierre Ossman 2006-12-30 04:44:39 EST
When you configure remote access in s-c-p, you get a cupsd.conf that uses @LOCAL
for access control. As I have a router in the middle of my network (mainly
allowing firewalling of the wireless access point), this forces me to manually
modify cupsd.conf after I've used s-c-p.

I'd like to see a check box that changes @LOCAL to ALL in the config file.
Comment 1 Tim Waugh 2007-01-04 12:01:18 EST
The problem is actually in CUPS.  The CUPS admin API, used as well in
http://localhost:631/admin, resets this BrowseAllow line.  We could add a
checkbox in system-config-printer, but as soon as someone changes a server
setting checkbox using the web interface the @LOCAL default will come back.

This awkward default (@LOCAL) was reported as a bug upstream in October.

Note You need to log in before you can comment on or make changes to this bug.