Bug 221006 - Segmentation fault when compiling blender mallocn.o
Segmentation fault when compiling blender mallocn.o
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-30 06:02 EST by patrik
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.1.1-30
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 17:48:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/ccuppxOd.out (67.50 KB, application/octet-stream)
2006-12-30 06:03 EST, patrik
no flags Details

  None (edit)
Description patrik 2006-12-30 06:02:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); sv-SE; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1

Description of problem:
When I trid to compile blender with scons building system I recieve this message:
[patrik@localhost blender-2.42a]scons
...
Compiling ==> 'mallocn.c'
intern/guardedalloc/intern/mallocn.c: In function ‘MEM_freeN’:
intern/guardedalloc/intern/mallocn.c:369: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccuppxOd.out file, please attach this to your bugreport.
scons: *** [/home/patrik/dev/cad/build/linux2/intern/guardedalloc/intern/mallocn.o] Error 1
scons: building terminated because of errors.
[patrik@localhost blender-2.42a]$ uname -a
Linux localhost.xxxxxxxxxx 2.6.18-1.2257.fc5 #1 SMP Fri Dec 15 16:07:14 EST 2006 x86_64 x86_64 x86_64 GNU/Linux
[patrik@localhost blender-2.42a]$ gcc --version
gcc (GCC) 4.1.1 20060525 (Red Hat 4.1.1-1)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

[patrik@localhost blender-2.42a]$


Version-Release number of selected component (if applicable):
gcc (GCC) 4.1.1 20060525 (Red Hat 4.1.1-1)

How reproducible:
Always


Steps to Reproduce:
1. Build blender from its source with scons
2.
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 patrik 2006-12-30 06:03:54 EST
Created attachment 144576 [details]
/tmp/ccuppxOd.out
Comment 2 Jakub Jelinek 2007-01-02 17:48:38 EST
Compiles just fine with gcc-4.1.1-30.
Comment 3 patrik 2007-01-04 11:05:34 EST
FC5 will not detect any newer version than the installed one. Where can I find
rpm for gcc-4.1.1-30?

Note You need to log in before you can comment on or make changes to this bug.