Bug 221022 - Please build netcdf as a shared library
Please build netcdf as a shared library
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: netcdf (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Hill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-30 07:23 EST by Julian Sikorski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-30 10:00:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2006-12-30 07:23:55 EST
Description of problem:
I am working on wrapping up a LabPlot package. It depends on a few dozens of
libraries, and netcdf is among these. The problem is that configure does not
detect system-wide netcdf (and tries to use local one) because ld can't find
-lnetcdf. I'm not sure if my request can be fulfilled easily, but I have noticed
that if you build LabPlot with local netcdf shared libLabPlotnetCDF.so.* files
get created.
Comment 1 Ed Hill 2006-12-30 09:05:49 EST
Hi Julian, I know nothing about LabPlot but I can say that:

 1) The next version of netCDF (due in ~2 months) will have full support
    for shared libs and I intend to upgrade the Fedora Extras version 
    to it shortly after its released (that is, out of beta).

 2) The current netCDF builds static libraries but it builds them as
    position-independent code (-fPIC) so the objects can be used within 
    the shared libraries of dependent software.  For an example, see
    the NCO package which does exactly that--it builds its own shared 
    libs using the netCDF static libs.

 3) Based on your description I think your LabPlot problem can be resolved
    by adding:

       export CPPFLAGS="-I/usr/include/netcdf-3"
       export LDFLAGS="-L/usr/lib/netcdf-3"

    to your environment before the "./configure ..." step.

If (3) doesn't fix things then I can probably help you fix whatever 
configure-and-build system is used by LabPlot.

If (3) does fix it then please respond and I'll close this bug.
Comment 2 Julian Sikorski 2006-12-30 09:52:32 EST
Thanks for the info, problem solved.

Note You need to log in before you can comment on or make changes to this bug.