Bug 221037 - [RFE] [PATCH] Wait for NFS server(s) to boot
[RFE] [PATCH] Wait for NFS server(s) to boot
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2006-12-30 17:14 EST by Pierre Ossman
Modified: 2014-03-16 23:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 10:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
nfswait (1.16 KB, text/plain)
2006-12-30 17:14 EST, Pierre Ossman
no flags Details
nfswait.patch (2.01 KB, patch)
2007-05-08 11:06 EDT, Pierre Ossman
no flags Details | Diff

  None (edit)
Description Pierre Ossman 2006-12-30 17:14:57 EST
A common scenario for smaller installations is that all servers reside on the
same UPS. This poses a problem when power comes back and all machines boot at
the same time. The machines depending on the NFS server will try a mount, get a
"connection refused" back, and give up.

What I'd like is for the machines to patiently wait for the NFS server to come
up, then proceed with the startup.

This could of course be extended to other network file systems, but NFS is my
particular itch.
Comment 1 Pierre Ossman 2006-12-30 17:14:57 EST
Created attachment 144586 [details]
nfswait
Comment 2 Pierre Ossman 2006-12-30 17:16:22 EST
Ooops...

		if [ $[ $now - $start ] -gt 120 ]; then

should of course be

		if [ $[ $now - $start ] -gt $RETRANS ]; then
Comment 3 Bill Nottingham 2007-01-01 23:22:12 EST
Hm, might be simpler to wire it into netfs rather than a separate script.
Comment 4 Pierre Ossman 2007-01-02 00:50:02 EST
Perhaps. The advantage of a separate service is that you can easily turn the
function on and off. But a variable somewhere in sysconfig could also do that job.
Comment 5 Pierre Ossman 2007-03-09 15:45:07 EST
Any comments on this or something more I'd need to do? Would be nice to have
this in standard FC.
Comment 6 Bill Nottingham 2007-04-16 19:08:13 EDT
I'd rather have a variable in sysconfig somewhere and do the wait in netfs itself.
Comment 7 Pierre Ossman 2007-05-08 11:06:39 EDT
Created attachment 154340 [details]
nfswait.patch

Sorry for taking so long.

How about this patch?
Comment 8 Bill Nottingham 2007-05-08 17:11:30 EDT
Aside from the logic seeming backwards (wait iff WAITFORNFS = "no"?), seems ok.
Will merge something along those lines post-F7.
Comment 9 Pierre Ossman 2007-05-09 01:40:09 EDT
The backwards logic is actually intentional. The idea is that the function is on
by default, and you turn it off via sysconfig.
Comment 10 Pierre Ossman 2007-11-14 04:53:25 EST
Since we're now post-F8, I was hoping to see this feature. Any progress?
Comment 11 Pierre Ossman 2008-01-01 10:02:28 EST
re-ping
Comment 12 Bill Nottingham 2008-01-07 14:35:50 EST
Putting on tracker. Sorry about the delay.
Comment 13 Jon Stanley 2008-04-23 16:29:01 EDT
Adding FutureFeature keyword to RFE's.
Comment 14 Lukáš Nykrýn 2013-03-14 10:25:54 EDT
Initscripts no longer handle this -> close.

Note You need to log in before you can comment on or make changes to this bug.