Bug 221042 - mkinitrd / nash create bad initrd and will not boot for raid10 rootfs
mkinitrd / nash create bad initrd and will not boot for raid10 rootfs
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
David Lawrence
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-30 19:36 EST by Sharif Nassar
Modified: 2008-05-06 13:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 13:16:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Best chance at nash script for initrd, no love (2.28 KB, text/plain)
2006-12-30 19:38 EST, Sharif Nassar
no flags Details

  None (edit)
Description Sharif Nassar 2006-12-30 19:36:27 EST
Description of problem:

The saga of raid10 continues.  The hard drives are mixed ATA & SATA.

Here's the original bug for FC5:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=190274

I have the same problem as before, but now I'm running FC6.
Not only does the initrd have bad information, but my hand-tuning no longer works.
Now when I manually load raid10 module,  no array is detected or created !

I'm stuck on the last FC5 kernel I used:  kernel-2.6.17-1.2174_FC5


Note:  I chose component "mkinitrd", but "nash" might be a better choice, except
it's not listed as a component in bugzilla.

Version-Release number of selected component (if applicable):

mkinitrd-5.1.19.0.2-1
nash-5.1.19.0.2-1
kernel-2.6.18-1.2868.fc6

How reproducible:

Use software raid10 and install a kernel RPM.

  
Actual results:

No root device, kernel panic!

Expected results:

A working system.
Additional info:
Comment 1 Sharif Nassar 2006-12-30 19:38:50 EST
Created attachment 144587 [details]
Best chance at nash script for initrd, no love


This is the latest hand-created non-working masterpiece.
When it boots, raidautorun doesn't create any raid10 devices.
no rootfs, kernel panic, sad mrwacky.
Comment 2 Csongor Fagyal 2007-01-09 11:40:12 EST
I had similar issues for a partitionable raid (/dev/md_d0NN), when I wanted to
move a non-raided system to RAID-1:

- System running on /dev/sda1
- Created /dev/md_d0
  mdadm -C -l1 --raid-devices=2 -ap /dev/md_d0 /dev/sdb,missing
- Partitioned /dev/md_d0
  fdisk => /dev/md_d0p1 (/boot), /dev/md_d0p2 (swap), /dev/md_d0p3 (/)
- new array is visible, mountable, ext3 created, system copied, etc...
- run mkinitrd with new fstab
- reboot
- no md_... devices found, kernel panic after trying to mount /dev/root (?)

I have tried to edit initrd by hand, but wasn't really successful: I have tried
to mess with raidstart (can raidstart start an md_d0 array?), with mount,
loading modules, recompile the kernel and include raid1, etc. but nothing
worked. (Probably one should have mdadm.static there?)

After two days of trying and Google-ing I have found this might be related to
this bug, or maybe to one of the followings:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=184570
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=216360
http://contribs.org/bugzilla/show_bug.cgi?id=961


Currently I see no way of switching over to a partitionable raid (the install
doesn't have this option, OTOH).
Comment 3 Bug Zapper 2008-04-04 01:25:16 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 4 Bug Zapper 2008-05-06 13:16:12 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.