This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 221043 - gtkmozembedmm has broken dependencies in devel/fc7
gtkmozembedmm has broken dependencies in devel/fc7
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtkmozembedmm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Haïkel Guémar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-12-30 20:40 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.4.2.cvs20060817-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 18:27:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-12-30 20:40:54 EST
Description of problem:

        gtkmozembedmm - 1.4.2.cvs20060817-5.fc7.i386    (38 days)
        gtkmozembedmm - 1.4.2.cvs20060817-5.fc7.i386    (38 days)
        gtkmozembedmm - 1.4.2.cvs20060817-5.fc7.ppc    (38 days)
        gtkmozembedmm - 1.4.2.cvs20060817-5.fc7.x86_64    (38 days)

    gtkmozembedmm-1.4.2.cvs20060817-5.fc7.ppc  requires  gecko-libs = 0:2.0
    gtkmozembedmm-1.4.2.cvs20060817-5.fc7.i386  requires  gecko-libs = 0:2.0
    gtkmozembedmm-1.4.2.cvs20060817-5.fc7.x86_64  requires  gecko-libs = 0:2.0
    gtkmozembedmm-1.4.2.cvs20060817-5.fc7.i386  requires  gecko-libs = 0:2.0

Looks like the package won't rebuild on devel/fc7... 

See: 

http://buildsys.fedoraproject.org/build-status/job.psp?uid=24387

For more details. 
Looks like the error is:

configure: error: cannot find install-sh or install.sh in scripts ./scripts
Comment 1 Haïkel Guémar 2007-01-04 03:40:28 EST
I still haven't found why it is broken in rawhide, the package builds fine on
fc6, even against FF2.0.x
Comment 2 Kevin Fenzi 2007-01-04 23:02:59 EST
Take a look at the 'scripts' directory thats shipped with the program: 

drwxr-xr-x 2 kevin mock 1024 Sep 14 08:24 .
drwxr-xr-x 9 kevin mock 1024 Sep 14 08:24 ..
lrwxrwxrwx 1 kevin mock   31 Jan  4 20:58 config.guess ->
/usr/share/libtool/config.guess
lrwxrwxrwx 1 kevin mock   29 Jan  4 20:58 config.sub ->
/usr/share/libtool/config.sub
lrwxrwxrwx 1 kevin mock   31 Jan  4 20:58 depcomp -> /usr/share/automake-1.9/depcomp
lrwxrwxrwx 1 kevin mock   34 Jan  4 20:58 install-sh ->
/usr/share/automake-1.9/install-sh
lrwxrwxrwx 1 kevin mock   28 Jan  4 20:58 ltmain.sh -> /usr/share/libtool/ltmain.sh
-rw-r--r-- 1 kevin mock 1419 Aug  4  2004 macros.m4
-rw-r--r-- 1 kevin mock   25 Aug  4  2004 Makefile.am
-rw-r--r-- 1 kevin mock 9892 Sep 14 08:24 Makefile.in
lrwxrwxrwx 1 kevin mock   31 Jan  4 20:58 missing -> /usr/share/automake-1.9/missing

Note that in devel, automake is: 

automake-1.10-2.noarch

So, all those automake-1.9 links are borken. 

So, at the very least you will need to remove and point all those links to 
automake-1.10. 

I'd be happy to test any potential fix for you. 
Comment 3 Haïkel Guémar 2007-01-06 12:41:38 EST
Thanks for your help.
After re-running the autogen script, the package now builds on rawhide.
Comment 4 Haïkel Guémar 2007-03-14 18:27:51 EDT
Updated the gecko-libs versionning.

Note You need to log in before you can comment on or make changes to this bug.