Bug 221083 - lesstif conflicts with openmotif
lesstif conflicts with openmotif
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lesstif (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2007-01-01 09:05 EST by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.95.0-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-01 20:36:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Patrice Dumas 2007-01-01 20:36:34 EST
I have added 
Obsoletes: openmotif <=  2.3.0-0.2.1
for lesstif, and

Obsoletes: openmotif-devel <=  2.3.0-0.2.1
for lesstif-devel

Hope it doesn't bother third party packaging of openmotif
Comment 2 Rex Dieter 2007-01-04 08:34:57 EST
imo, only the
Obsoletes: openmotif-devel
should have been added.

afaict, there are no runtime conflicts to warrant
Obsoletes: openmotif
Comment 3 Patrice Dumas 2007-01-04 08:45:23 EST
Indeed, but otherwise openmotif is left over. Given that the devel
package is obsoleted I find it more coherent to also obsolete
openmotif shipped with fedora. That way a user have to use a 
newer openmotif, not the one not supported anymore.
Comment 4 Rex Dieter 2007-01-04 08:52:44 EST
> I find it more coherent to also obsolete openmotif shipped with fedora

Doesn't matter, frankly.  It's *not your problem*.  Please remove it.  There's a
reason I made it clear as MUST item in the package review.  
Comment 5 Patrice Dumas 2007-01-04 09:08:46 EST
Ok, I removed it. It could be readded later, if needed.
Comment 6 Rex Dieter 2007-01-04 09:11:53 EST
Thanks.
Comment 7 Michael Schwendt 2007-01-04 11:09:39 EST
Just some more advice, now that a package review ticket has been
referred to:

Bug 203274 comment 11 is misguidance. Any "Provides:" openmotif*
would be very wrong. LessTif is not OpenMotif. LessTif is not renamed
to OpenMotif, it does not provide OpenMotif either. I back up Ralf in
that LessTif should have been added to the distribution in a form
that permits co-existence with the available OpenMotif packages. It is
somewhat rude to kick out OpenMotif, block the standard search path for
Motif headers, and require 3rd party packages to work around that
within their packages by choosing non-standard install locations.
Okay, distributors kick out packages like that sometimes when it meets
their preferences, and they do it also with applications. I don't mind.
It is poor, however, that after upgrades obsolete and orphaned packages
stay installed because the upgrade doesn't remove stuff that has been
dropped from the distribution and maintenance cycle.

Semantically, the LessTif packages in Fedora Extras obsolete the 
openmotif/openmotif-devel packages by providing an API-compatible
replacement, an alternative Motif implemenation. This does not mean
that developers should get lesstif-devel when running something like
"yum install openmotif-devel". For developers and packagers the switch
to LessTif cannot be transparent. OpenMotif is not available anymore in
the distribution, the Yum command should fail, not install a wrong
product.
Comment 8 Patrice Dumas 2007-01-04 11:33:16 EST
(In reply to comment #7)
> Just some more advice, now that a package review ticket has been
> referred to:
> 
> Bug 203274 comment 11 is misguidance. Any "Provides:" openmotif*
> would be very wrong. 

There is no provides for openmotif in lesstif. There are changing 
obsolete and conflicts.

> I back up Ralf in
> that LessTif should have been added to the distribution in a form
> that permits co-existence with the available OpenMotif packages. It is
> somewhat rude to kick out OpenMotif, block the standard search path for
> Motif headers, and require 3rd party packages to work around that
> within their packages by choosing non-standard install locations.

I am still open to change the paths used in lesstif to help parallel
installation with openmotif. I am waiting to be contacted by openmotif
packagers to coordinate. In the mean time it is less work for lesstif,
and for package depending on lesstif to have everything in the default 
paths.

> Okay, distributors kick out packages like that sometimes when it meets
> their preferences, and they do it also with applications. I don't mind.
> It is poor, however, that after upgrades obsolete and orphaned packages
> stay installed because the upgrade doesn't remove stuff that has been
> dropped from the distribution and maintenance cycle.

I still haven't seen a perfect solution: with obsoletes the packages are
removed, but it may hurt third party packaging. 
 
> Semantically, the LessTif packages in Fedora Extras obsolete the 
> openmotif/openmotif-devel packages by providing an API-compatible
> replacement, an alternative Motif implemenation. This does not mean
> that developers should get lesstif-devel when running something like
> "yum install openmotif-devel". For developers and packagers the switch
> to LessTif cannot be transparent. OpenMotif is not available anymore in
> the distribution, the Yum command should fail, not install a wrong
> product.

I think we all agree on that, and that's what happens now, since there 
is no Provides for openmotif-devel, only an Obsolete.
Comment 9 Patrice Dumas 2007-01-05 06:18:44 EST
To fix Bug 215560, I also added
Obsoletes: openmotif21 <= 2.1.30-17.1.1

I am not worried about disturbing 3rd party packaging with 
that change, however, but about breaking custom software
and packages that were linked against openmotif21

Note You need to log in before you can comment on or make changes to this bug.