Bug 221096 - yumex wont run after upgrade from FC4 to FC6
yumex wont run after upgrade from FC4 to FC6
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-01 15:02 EST by Joe Acosta
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 09:49:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2007-01-01 15:02:14 EST
Description of problem:  yumex wont run after upgrading from FC4 to FC6

get a DVD of FC6 and install on an FC4 machine.


Version-Release number of selected component (if applicable): 


How reproducible: always


Steps to Reproduce:
1. startx
2. open terminal window of your choice
3. run yumex
4. it does not run 
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 35, in ?
    import yumex.yumexConst as const
  File "__init__.py", line 30, in ?
  File "yumexDialogs.py", line 29, in ?
  File "yumexUtils.py", line 38, in ?
ImportError: cannot import name IncludingConfigParser


Expected results: it runs and you have a pretty GUI to yum


Additional info: see traceback.  

I don't think the upgrade upgraded everything or installed all the dependancies
it should.  For instance, gnome started complaining about gnome-setting-deamon
could not start.  So I had to get a traceback and found dbus-x11 was not
installed.  Now that message goes away.  Also when I tried to run yum update it
complained about an mplayer dependancy, so I had to uninstall mplayer to to the
update.

This is really weird because when I ran rpm -qa|grep yumex it is not found, yet
I can run the yumex command.  

I just ran yum install yumex and now it seems to be working.  

So the bug is that you can run the yumex command without yumex being installed
after the upgrade.
Comment 1 Tim Lauridsen 2007-01-03 09:49:19 EST
FC4 as working with yumex 1.0.x, FC6 runs with yumex 1.2.z.
After an upgrade from FC4 -> FC6, a yum update has to be performed to upgrade
Extras packages to the right version.

Comment 2 Joe Acosta 2007-01-03 12:16:47 EST
I would think that the install should tell a user at the end of the install to
run yum update, but that is just me from a GUI design perspective, which is what
I do for a living.  Think 'dumb user wont know this', and probably wont read
release notes.  I know I don't read release notes till something goes wrong ;-).
 
If it were me, I'd have the installer say, do you want to get all the updates to
your system now, after the install BEFORE the first boot.  

Why before?  My system would not boot, because I had lapic on the command line,
which worked when I used my own custom kernel but now does not with the default
SMP kernel that you all ship.    

I did run yum update, and found I had to uninstall some programs to get yup
update to actually do an update.  The update did not update everything, as I
have found several other programs missing or not working.  I also found some bad
info on the internet that said you should setup the lazlo(?) and freshrpms
repositories, but later found out these are incompatible and one should only
setup one of the other in other to get things like mplayer and/or xine with DVD
support.  This was because after finally reading the release notes, I saw the
part on DVD and mp3.  Personally I recommend freshrpms as things from there
actually work and the other one had some buggy stuff there.

I am not in the process of finding out that if a menu launcher does not launch a
program that I need to run yum install to install the package.  I have no idea
at this point what may or may not be installed.  

Is there a good test?  Oh and doing a fresh install is not an option at this point.
 
Comment 3 Tim Lauridsen 2007-01-04 05:01:51 EST
I agree it can be a mess upgrading a system, because a lot of non core
application, will not work anymore, and it can be hard to get them to work.
I always backup my homedir and do a clean install, it faster and don't leave a
lot  of broken old stuff behind.
Another approach is to remove the 3.part packages before updating.
you can run a 'yum list extras' as root, with only the core, updates and extras
repos enabled, it will show you a list of packages not available in the repos.
In FC6 there is a update applet there check for updates and let you update your
system with the pup updater. I should solve the updating of Extra packages
including yumex.
Another issue is that you have jumped over a release (FC4 -> FC6) it will give
you some extra troubles, because the Fedora Core is moving so fast.
It is right there is some issues mixing repositories (freshrpms and livna), but   
it not so big a problem in FC6, that it was in FC4. 
Comment 4 Joe Acosta 2007-01-04 12:31:35 EST
Actually one of the issues that I ran into after the first yum update was with
mixing those two repos.  Both mplayer and xine are in both repos as is ffmpeg. 
So when I tried yum install mplayer it got confused between the two repos.  That
was one issue I had. 

FC6 seems to have come out so quick after FC5 I did not have time it seems. 
Maybe I'm just missing some time ;-).  Actually one of the reasons I did not go
to 5 was because I figured 6 would be out soon after I heard of 5.

Is thunderbird in the extras?  It seems I had to reinstall that.  Yeah, one
could shuve the responsibility of 3.party pkgs and extras on the end user.  

I guess before upgrades I'll have to do a yum list > old and after the upgrade
do a yum list > new and then write a perl script to compare the two to see what
was in the old that is not in the new.  

Note You need to log in before you can comment on or make changes to this bug.