Bug 221105 - inconsistent directory permissions
inconsistent directory permissions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: leafnode (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-01 16:22 EST by Christian Krause
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.11.5-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-25 12:41:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Krause 2007-01-01 16:22:33 EST
Description of problem:
the permission of the /var/spool/news directory in the rpm package does not
match the permissions which are set by a running leafnode

Version-Release number of selected component (if applicable):
leafnode-1.11.5-2.fc6.i386.rpm

How reproducible:
100%

Steps to Reproduce:
1. install leafnode
2. run leafnode
3. rpm -V leafnode
  
Actual results:

root@moria:/var/spool/news# rpm -V leafnode
S.5....T c /etc/leafnode/config
S.5....T c /etc/xinetd.d/leafnode
.M......   /var/spool/news
.M......   /var/spool/news/failed.postings
.M......   /var/spool/news/interesting.groups
.M......   /var/spool/news/leaf.node
.M......   /var/spool/news/message.id
.M......   /var/spool/news/out.going

Expected results:
The permissions of the /var/spool/news directories should match the permissions
of the rpm package.
Comment 1 Kevin Fenzi 2007-01-01 19:17:58 EST
Thanks for the bug report.

I will take a look and see what I can figure out. 
Comment 2 Kevin Fenzi 2007-01-23 00:44:46 EST
ok. I just checked in and built a fix for this. 
Should be out in the next day or so... if you would like to test a non signed 
rpm, you can find it here:

http://buildsys.fedoraproject.org/logs/fedora-6-extras/26259-leafnode-1.11.5-
3.fc6/

If you could test the package there, or wait and test it when it's released as 
an update and let me know if you spot any problems I would appreciate it. 

Thanks again for the bug report. 
Comment 3 Kevin Fenzi 2007-01-23 21:38:05 EST
The updated package was pushed out today. 
Could you test and confirm that the updated package fixes the permissions?
Comment 4 Christian Krause 2007-01-28 15:50:37 EST
Hi Kevin,

Please apologize, that I haven't had the time to test the unsigned rpm.
I've checked the current leafnode package, and it seems most of the permission
problemss are fixed. Thank you very much for taking care of it!

There is only one small glitch left:

/var/spool/news/out.going is always set automatically to non-matching settings:

root@:~# chmod 2775 /var/spool/news/out.going
root@:~# rpm -V leafnode
S.5....T c /etc/leafnode/config
S.5....T c /etc/xinetd.d/leafnode

[since now everything is fine]

root@:~# su - news
news@:~$ /usr/sbin/fetchnews
news@:~$
root@:~# rpm -V leafnode
S.5....T c /etc/leafnode/config
S.5....T c /etc/xinetd.d/leafnode
.M......   /var/spool/news/out.going
root@:~# 

[but after using e.g. fetchnews or reading news, the permissions of out.going
are wrong again.

Best regards,
Christian
Comment 5 Kevin Fenzi 2007-01-28 16:52:59 EST
Rats. I thought I got them all. 
I use leafnode extensively on my laptop, so it's easy for me to test. 
I must have missed the out.going dir somehow. ;( 

I'll see about fixing that soon... 

Thanks for your patience. 
Comment 6 Kevin Fenzi 2007-02-21 23:44:23 EST
Sorry for the delay here. 

I just pushed out an update that hopefully fixes that last permission issue. 
You can test out a unsigned version of this update at: 
http://buildsys.fedoraproject.org/plague-results/fedora-6-extras/leafnode/

Or just wait a day or two and it should be pushed out...

please let me know if you spot any further issues with this update. 
Comment 7 Christian Krause 2007-02-25 12:03:14 EST
Hi Kevin,

I've installed the new signed package and all problems are solved!

Thank you very much for the updated package!

So the bug can be closed as "fixed". I assume the appropriate status would be
CURRENTRELEASE, but I'm not sure. - so I let it up to you to close it. ;-)

Best regards,
Christian
Comment 8 Kevin Fenzi 2007-02-25 12:41:57 EST
Thanks for the report and good feedback. :) 

If you spot any further problems feel free to file a new bug. 

Note You need to log in before you can comment on or make changes to this bug.