Bug 221106 - X hangs with 100% cpu usage during logout
X hangs with 100% cpu usage during logout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-sis (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-01 16:30 EST by Rafael Ávila de Espíndola
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 11:37:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log (41.15 KB, text/plain)
2007-01-01 16:30 EST, Rafael Ávila de Espíndola
no flags Details
xorg.conf (565 bytes, application/octet-stream)
2007-01-02 13:51 EST, Rafael Ávila de Espíndola
no flags Details
new Xorg.0.log (with xorg.conf, without acpi) (38.79 KB, text/plain)
2007-01-02 13:54 EST, Rafael Ávila de Espíndola
no flags Details

  None (edit)
Description Rafael Ávila de Espíndola 2007-01-01 16:30:37 EST
Description of problem:

X hangs with 100% cpu usage during logout. The keyboard is dead (Ctrl + Alt + F1
or + backspaece doesn't work). The mouse cursor works but otherwise the screen
is blank.

Loging via ssh and killing X (kill -9) solves the problem.

Version-Release number of selected component (if applicable):
xorg-x11-drv-sis-0.9.1-7

How reproducible:
Login and Logout. Approximately 1 in 10 times X halts.
Comment 1 Rafael Ávila de Espíndola 2007-01-01 16:30:38 EST
Created attachment 144614 [details]
xorg log
Comment 2 Rafael Ávila de Espíndola 2007-01-02 09:15:22 EST
I have booted the system with acpi=off, but it didn't solve the problem
Comment 3 Matěj Cepl 2007-01-02 10:08:02 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) as well to the bug
report  as individual uncompressed file attachments using the bugzilla file
attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Rafael Ávila de Espíndola 2007-01-02 13:48:52 EST
I will attach the requested files in a minute. I have upgraded the sis driver to
version 0.9.3 by compiling and installing the package from fedora devel. I\
 have also installed the dubug symbols. The trace printed by gdb is:

#0  0x0035e402 in __kernel_vsyscall ()
#1  0x4d85996e in __lll_mutex_lock_wait () from /lib/libc.so.6
#2  0x4d7ea01e in _L_lock_14512 () from /lib/libc.so.6
#3  0x4d7e9544 in free () from /lib/libc.so.6
#4  0x0079770d in _mesa_free () from /usr/lib/xorg/modules/extensions/libGLcore.so
#5  0x009242bd in XMesaDestroyVisual () from
/usr/lib/xorg/modules/extensions/libGLcore.so
#6  0x00937682 in GlxGetMesaProvider () from
/usr/lib/xorg/modules/extensions/libGLcore.so
#7  0x0051a997 in __glXResetScreens () from
/usr/lib/xorg/modules/extensions/libglx.so
#8  0x00519bdc in GlxExtensionInit () from
/usr/lib/xorg/modules/extensions/libglx.so
#9  0x08095676 in CloseDownExtensions ()
#10 0x0806fa7f in main ()

I will install the missing symbols and report again when it halts.
Comment 5 Rafael Ávila de Espíndola 2007-01-02 13:51:45 EST
Created attachment 144659 [details]
xorg.conf
Comment 6 Rafael Ávila de Espíndola 2007-01-02 13:54:35 EST
Created attachment 144660 [details]
new Xorg.0.log (with xorg.conf, without acpi)
Comment 7 Rafael Ávila de Espíndola 2007-01-03 20:13:16 EST
new back trace:

#0  0x008f1400 in __kernel_vsyscall ()
#1  0x4d85996e in __lll_mutex_lock_wait () from /lib/libc.so.6
#2  0x4d7ea01e in _L_lock_14512 () from /lib/libc.so.6
#3  0x4d7e9544 in free () from /lib/libc.so.6
#4  0x00fa270d in _mesa_free (ptr=0x18) at imports.c:116
#5  0x0112f2bd in XMesaDestroyVisual (v=0x18) at xm_api.c:1646
#6  0x01142682 in __glXMesaScreenDestroy (screen=0x18) at xf86glx.c:299
#7  0x00aaa997 in __glXResetScreens () at glxscreens.c:321
#8  0x00aa9bdc in ResetExtension (extEntry=0xa16f778) at glxext.c:49
#9  0x08095676 in CloseDownExtensions () at extension.c:280
#10 0x0806fa7f in main (argc=8, argv=0xbfa52ea4, envp=0xf000e2c3) at main.c:453

Now it looks like a libc bug. The strange thing is that there is only one thread
running. What mutex is free waiting for?
Comment 8 Sylvain Defresne 2007-01-10 16:25:20 EST
I'm also encountering this bug. Concerning the previous stacktrace, the bug
seems to be in __glXResetScreens that call __glXResetScreens with aninvalid
pointer (0x18) that is later passed to free ...
Comment 9 Adam Jackson 2007-03-28 11:37:56 EDT
Should be fixed in 1.1.1-47.6 and later.  Please update, and reopen if this is
still an issue for you. 
Comment 10 Rafael Ávila de Espíndola 2007-05-02 19:20:46 EDT
were can I found this version? core/development/i386/os/Fedora/ only shows 0.9.3-2
Comment 11 Rafael Ávila de Espíndola 2007-05-03 17:29:37 EDT
I was looking at the wrong package. The updated one is xorg-x11-server-Xorg.
Sorry about that :-(

Note You need to log in before you can comment on or make changes to this bug.