Bug 221114 - RFE: Latest libmtp for Fedora Core 6
RFE: Latest libmtp for Fedora Core 6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-01 18:58 EST by Gian Paolo Mureddu
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.1.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-10 08:42:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2007-01-01 18:58:49 EST
Recently there has been three releases of libmtp which has already reached Beta
status (from the previous alpha status in the 0.0.x versions) which are 0.1.0,
0.1.1 and 0.1.2; these releases are compatible with devices that use the second
incarnation of the MTP protocol in devices such as portable digital media
players similar to the iPod (iriver Clix, Creative Zen, Microsoft's Zune, etc).
The latest version available for Fedora Core 6 is 0.0.21 which is apparently the
latest alpha version, however the newer version has support for more devices.

I am aware that other programs (such as Amarok) depend on this library, and I'm
not sure what it would be needed for Amarok to support libmtp 0.1.x or if only a
rebuild might do it.

Benefits from using libmtp 0.1.x over 0.0.2x include (from first hand experience):

1. The device is less prone to blocking when performing operations on it and one
or more failing (meaning it has to be unplugged/replugged into the computer for
the mtp- commands to work)

2. More options to transfer data onto the devices, and in the command line one
command to send files, tracks, delete files, create directories and get files
(mtp-connect) from mtp devices.

3. Support for a wider range of actions (like album art, thumbnails and
playlists [mtp-newplaylist].

For full details consult http://libmtp.sf.net
Comment 1 Linus Walleij 2007-01-02 10:36:11 EST
I know I am a developer on libmtp and its release manager and I
also wrote that webpage actually :-)

The reason I didn't put libmtp 0.1.x into FC6 is that if I do,
I break dependencies for all packages using libmtp since the
library interface changed from libmtp.so.4 to libmtp.so.5.

This means every package that use libmtp would need to be updated
too.

Avoiding these situations is one of the main reasons to why Core
is released so often: at these timelaps we get the chance to
swap out libraries with new interfaces. If you want to be bleeding
edge typically you should use devel. (Rawhide.)

That said, we sometimes sneak new libraries into old releasea as
well.. I'm putting the Amarok maintainer onto this bug to hear
what he has to say about it. Currently only gnomad2 and Amarok
use libmtp I think, so would be OK for me to upgrade if there is
sufficient demand (causing a small breakage in the repos for a
short lapse of time).
Comment 2 Linus Walleij 2007-01-02 10:38:27 EST
Gauret, what do you say, shall we upgrade FC6 to libmtp 0.1.2?
Comment 3 Gian Paolo Mureddu 2007-01-02 19:32:00 EST
That would be awesome if it could be backported to Core 6 I know it is available
for the pre-test-releases of Core 7, and I know I don't only speak for myself
when I say that many, many users of devices such as iriver Clix (I'm the proud
owner of one of those little fellas), Creative Zen and many others will be more
than thrilled to be able to use their devices in Linux with one of the most
impressive media players there is, Amarok (or use it with a dedicated
application such as gnomad2, if any user does not like/use Amarok). Actually at
some forums it seems to me that Linux (and MacOS/BSD) support is often requested.
Comment 4 Aurelien Bompard 2007-01-11 09:38:55 EST
I'm perfectly OK with rebuilding Amarok if a new version of libmtp requires it.
Please warn me by direct mail when you plan to do that, to limit the breakage
Comment 5 Linus Walleij 2007-01-24 14:10:01 EST
OK we have libmtp 0.1.3 and I also have a working Gnomad 2.8.10
both are in devel. Aurelien, when you have a working Amarok in
devel so we know how to handle this, tell me and I'll push libmtp 
0.1.3 into FC6 and FC5.
Comment 6 Aurelien Bompard 2007-01-25 16:45:13 EST
Amarok won't build with the new libmtp in devel :
http://buildsys.fedoraproject.org/logs/fedora-development-extras/26365-amarok-1.4.4-7.fc7/i386/build.log
Any idea ?
Comment 7 Linus Walleij 2007-01-26 03:03:18 EST
The API has changed in libmtp, specifically the LIBMTP_Get_Storage()
function is changed.

You need to check upstream for patches.... Or there will soon be a newer
Amarok.

We will hold any migration to FC-6/5 until it's solved.
Comment 8 Aurelien Bompard 2007-02-06 16:19:01 EST
Amarok 1.4.5 is out, it supports the new libmtp. It builds fine in devel, please
migrate FC-6 to the new libmtp and I'll build the new amarok there too.
Thanks.
Comment 9 Linus Walleij 2007-02-07 04:44:23 EST
OK I have now pushed a build of libmtp 0.1.3 for FC5 and FC6. Please
rebuild these as soon as it is available. (I think the build machines
are instantly upgraded, so you can probably build it now, I will test
with gnomad2 now.)
Comment 10 Gian Paolo Mureddu 2007-02-08 00:51:05 EST
When could we expect to see in the repos both Amarok-1.4.5 and Gnomad-2.8.11 (or
whichever is going to be released for Core 6)? I'm really at the edge of my seat
to test these puppies with my Clix.
Comment 11 Linus Walleij 2007-02-08 03:26:38 EST
Ville Skyttä does not like the way we handled this, copying in mail from the
Fedora Extras devel list:

Date: Wed, 7 Feb 2007 18:45:29 +0200
From: Ville Skyttä
Subject: libmtp soname change breakage (was: Re: Summary - Broken
    dependencies in Fedora Extras - 2007-02-07)

On Wednesday 07 February 2007 14:38, Fedora Extras repoclosure wrote:
                                                                                
> package: amarok - 1.4.4-1.fc5.i386 from fedora-extras-5-i386
>   unresolved deps:
>      libmtp.so.2
                                                                                
Ditto:

> package: amarok - 1.4.4-1.fc5.ppc from fedora-extras-5-ppc
> package: amarok - 1.4.4-1.fc5.x86_64 from fedora-extras-5-x86_64
> package: amarok - 1.4.4-7.fc6.i386 from fedora-extras-6-i386
> package: amarok - 1.4.4-7.fc6.ppc from fedora-extras-6-ppc
> package: amarok - 1.4.4-7.fc6.x86_64 from fedora-extras-6-x86_64
> package: gnomad2 - 2.8.9-2.fc5.i386 from fedora-extras-5-i386
> package: gnomad2 - 2.8.9-2.fc5.ppc from fedora-extras-5-ppc
> package: gnomad2 - 2.8.9-2.fc5.x86_64 from fedora-extras-5-x86_64
> package: gnomad2 - 2.8.9-2.fc6.i386 from fedora-extras-6-i386
> package: gnomad2 - 2.8.9-2.fc6.ppc from fedora-extras-6-ppc
> package: gnomad2 - 2.8.9-2.fc6.x86_64 from fedora-extras-6-x86_64
                                                                                
Linus, was the soname change of libmtp announced somewhere in public
beforehand?  Why was it necessary push the update to non-devel distros?
Apologies if I missed the announcement, but based on the above list of
breakage I'm not alone even within Fedora maintainers, let alone elsewhere.

In case you're not aware of it, yum (more or less by design AFAIK) bumps the
severity of a single dependency problem among a batch of updates into the
*sum* of all other problems fixed in the batch, including security ones and
across all repos, by refusing to install any of them unless the user
manually
cherry picks the packages not affected by the dependency issue separately.
This is what users of amarok and/or gnomad2 on FC-5 and FC-6 have to deal
with right now, and maintainers need to take it extra carefully into account
at all times as long as yum has anywhere near the significant role it
currently has or is fixed.

FESCO, what's the status of the incompatible package upgrade policy?  I
didn't
find it in Wiki nor the FESCO schedule.  At the very least, instructions how
packagers must communicate (where, how long beforehand, rationale of the
update) incoming incompatible upgrades needs to be put somewhere and people
made aware of it.
Comment 12 Gian Paolo Mureddu 2007-02-08 10:09:41 EST
I'm guessing here, but since the build machines need to already have the
necessary dependency for the other packages (libmtp in this case to build either
gnomad and/or Amarok), this poses a chicken and egg kind of problem, worsened by
the time it takes the build machines to deply such necessary update (or at least
that's the way I see it)
Comment 13 Jérôme Benoit 2007-02-08 13:32:56 EST
Hello,

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package yum-utils.noarch 0:1.0.2-2.fc6 set to be updated
---> Package yum-fastestmirror.noarch 0:1.0.2-2.fc6 set to be updated
---> Package yum-changelog.noarch 0:1.0.2-2.fc6 set to be updated
---> Package libmtp.i386 0:0.1.3-1.fc6 set to be updated
---> Package postgresql-libs.i386 0:8.1.8-1.fc6 set to be updated
---> Package beryl-manager.i386 0:0.1.9999.1-2.fc6 set to be updated
---> Package beryl-settings-simple.i386 0:0.1.9999.1-3.fc6 set to be updated
---> Package beryl-settings.i386 0:0.1.9999.1-3.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: libmtp.so.2 for package: amarok
--> Finished Dependency Resolution
Error: Missing Dependency: libmtp.so.2 is needed by package amarok

The latest amarok build do not seem do have been built against this new lib ... 

Aurelien, are you planning to rebuild it against this new version of libmtp ?

Thanks
Comment 14 Gian Paolo Mureddu 2007-02-08 13:43:02 EST
The Amarok in the repos is still 1.4.4, the one Aurelien is building is 1.4.5
(which has support for this verision of libmtp), it hasn't been pushed to the
repos, though. I had to manually update with pup and leave out libmtp, not a biggie.
Comment 15 Michael Schwendt 2007-02-08 14:01:15 EST
The version in the master repo _is_ 1.4.5, proof is here:

https://www.redhat.com/archives/fedora-extras-list/2007-February/msg00078.html
http://fedoraproject.org/extras/6/i386/repodata/repoview/amarok-0-1.4.5-1.fc6.html

Give your mirrors a chance to sync.
Comment 16 Gian Paolo Mureddu 2007-02-08 14:13:38 EST
So it finally got there... It wasn't yesterday, and still today was not
available... Will keep doing "yum update" :)

Thanks for the heads up! 
Comment 17 Gian Paolo Mureddu 2007-02-08 14:21:03 EST
I can confirm this, I'm getting the updates as I type this, THANK YOU VERY MUCH,
Linus and Aurelien and anyone else involved (maybe I can finally kick Windows
good bye!)
Comment 18 Gian Paolo Mureddu 2007-02-08 14:35:13 EST
I can confirm so far, that my Clix works flawlessly with Gnomad2, I still have
to test with Amarok, but I'm very confident it will work just as well.
Comment 19 Michael Schwendt 2007-02-08 14:46:29 EST
When the Fedora Extras Build Report hits the mailing list, the master
repo is up-to-date already. The time-stamp in the mail is the time of
when Amarok 1.4.5 was available in the repo:
Thu, 8 Feb 2007 05:49:42 -0500 (EST) which is 11:49 CET or 9 hours ago
Comment 20 jouni 2007-02-09 15:50:14 EST
Is this known allready:

$ gnomad2 -D1
Enter view_and_sort_list_store(0)...
Enter view_and_sort_list_store(2)...
Adding dir entry: , size 3792142
Adding dir entry: , size 3547218
Adding dir entry: , size 3482852
Adding dir entry: , size 3558921
Adding dir entry: , size 0
Adding dir entry: , size 3030621
Adding dir entry: , size 3199058
Adding dir entry: , size 3947205
Getting metadata for: . (1/8)

Segmentation fault



gnomad2-2.8.11-1.fc6
libmtp-0.1.3-1.fc6
Comment 21 Linus Walleij 2007-02-10 08:42:37 EST
The latest error should be filed with gnomad2 with reproduction info,
please.

libmtp is upgraded now, so closing.

Note You need to log in before you can comment on or make changes to this bug.