Bug 221147 - LTC15167-SystemError: lvremove failed during installation
LTC15167-SystemError: lvremove failed during installation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.4
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: 234547
  Show dependency treegraph
 
Reported: 2007-01-02 09:09 EST by Gavin Romig-Koch
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 17:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gavin Romig-Koch 2007-01-02 09:09:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060418 Fedora/1.0.8-1.1.fc4 Firefox/1.0.8

Description of problem:
This was previously https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=200252 which was closed for lack of clarity.  What follows is the TAM's attempt to clarify the issue.


Steps to reproduce:
----------------------------------------------------------------------------------
This problem has been reproduced by the following process on rhel4 qu4 beta2.
1. Install RHEL4 QU4 with only virtual disk A attached- Success;
2. Install RHEL4 QU4 with only virtual disk B attached - Success;
3. Install RHEL4 QU4 with both virtual disk A and B attached - Error.

Red Hat Enterprise Linux AS (C) 2004 Red Hat, Inc.
             ┌────────────┤ Exception Occurred ├──┐
             │                                               │
             │ An unhandled exception has occurred.        # │
             │ This is most likely a bug.  Please copy     ▒ │
             │ the full text of this exception and file    ▒ │
             │ a detailed bug report against anaconda at   ▒ │
             │ http://bugzilla.redhat.com/bugzilla/        ▒ │
             │                                             ▒ │
             │ Traceback (most recent call last):          ▒ │
             │   File "/usr/bin/anaconda", line 1181, in   ▒ │
             │ ?                                           ▒ │
             │     intf.run(id, dispatch, configFileData)  ▒ │
             │   File                                      ▒ │
             │ "/usr/src/build/758992-ppc/install//usr/li  ▒ │
             │ b/anaconda/text.py", line 510, in run       ▒ │
             │     dispatch.gotoNext()                     ▒ │
             │   File                                      ▒ │
             │ "/usr/src/build/758992-ppc/install//usr/li  # │
             │ b/anaconda/dispatch.py", line 171, in       ▒ │
             │ gotoNext                                    ▒ │
             │     self.moveStep()                         ▒ │
             │   File                                      ▒ │
             │ "/usr/src/build/758992-ppc/install//usr/li  ▒ │
             │ b/anaconda/dispatch.py", line 239, in       ▒ │
             │ moveStep                                    ▒ │
             │     rc = apply(func, self.bindArgs(args))   ▒ │
             │   File                                      ▒ │
             │ "/usr/src/build/758992-ppc/install//usr/li  ▒ │
             │ b/anaconda/packages.py", line 564, in       ▒ │
             │ turnOnFilesystems                           ▒ │
             │     partitions.doMetaDeletes(diskset)       ▒ │
             │   File                                      ▒ │
             │ "/usr/src/build/758992-ppc/install//usr/li  ▒ │
             │ b/anaconda/partitions.py", line 1205, in    ▒ │
             │ doMetaDeletes                               # │
             │     lvm.lvremove(delete.name, delete.vg)    ▒ │
             │   File                                      ▒ │
             │ "/usr/src/build/758992-ppc/install//usr/li  ▒ │
             │ b/anaconda/lvm.py", line 143, in lvremove   ▒ │
             │     raise SystemError, "lvremove failed"    ▒ │
             │ SystemError: lvremove failed                # │
--------------------------------------------------------------------

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
See description.

Actual Results:


Expected Results:


Additional info:
Comment 1 RHEL Product and Program Management 2007-01-02 09:20:50 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Jeremy Katz 2007-01-15 13:28:56 EST
Please attach the complete traceback that was received.
Comment 10 Alasdair Kergon 2007-02-27 11:50:26 EST
Extract of lvm2 messages from report:

  Volume group VolGroup00 metadata is inconsistent
  Volume group for uuid not found:
g5vgtzDFzM0eYlvEq1f3euw8wi5ttH55K2sMouVX97215rmbjERnCX9u9c1rlIUH
  Unable to deactivate logical volume "LogVol01"
  Inconsistent metadata copies found - updating to use version 17

(There have been changes to this logic since the version run here.)
Comment 11 RHEL Product and Program Management 2007-03-09 19:53:38 EST
This bugzilla had previously been approved for engineering
consideration but Red Hat Product Management is currently reevaluating
this issue for inclusion in RHEL4.6.
Comment 13 RHEL Product and Program Management 2007-05-09 04:26:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 14 Issue Tracker 2007-06-11 09:10:20 EDT
----- Additional Comments From mranweil@us.ibm.com (prefers email at
mjr@us.ibm.com)  2007-06-08 18:31 EDT -------
Red Hat - this has been a long journey with this one.  I think the
remaining
issues on this side are going to possibly be covered by a feature.  I
don't know
if there's more work planned on your side (for 4.6 or later) that we
should keep
this bug open or not.  Any thoughts? 


This event sent from IssueTracker by jkachuck 
 issue 70738
Comment 17 David Cantrell 2007-08-21 17:48:12 EDT
Setting devel-nak per comment #15.
Comment 18 RHEL Product and Program Management 2007-08-21 17:51:26 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.