Bug 2211577 - libwbclient 2:4.18.2-0.fc38 cannot be selected above & appears to have created a broken symlink
Summary: libwbclient 2:4.18.2-0.fc38 cannot be selected above & appears to have create...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 38
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Denis Karpelevich
URL:
Whiteboard:
Depends On:
Blocks: 2216712 2221594
TreeView+ depends on / blocked
 
Reported: 2023-06-01 06:09 UTC by John Dodson
Modified: 2023-07-14 02:35 UTC (History)
12 users (show)

Fixed In Version: samba-4.18.3-3.fc39 samba-4.18.3-3.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 2216712 (view as bug list)
Environment:
Last Closed: 2023-06-23 10:57:06 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description John Dodson 2023-06-01 06:09:27 UTC
libwbclient 2:4.18.2-0.fc38 cannot be selected above (is it samba?) & appears to have created a broken symlink

/etc/alternatives/libwbclient.so.0.15-64: broken symbolic link to /usr/lib64/samba/wbclient/libwbclient.so.0.15
file /etc/alternatives/libwbclient.so.0.15-64 is not owned by any package


Reproducible: Always

Steps to Reproduce:
1. /etc/alternatives/libwbclient.so.0.15-64: broken symbolic link to /usr/lib64/samba/wbclient/libwbclient.so.0.15
file /etc/alternatives/libwbclient.so.0.15-64 is not owned by any package
2. The link /usr/lib64/samba/wbclient/libwbclient.so.0.16/libwbclient.so.0.16 does exist!
3. Typo somewhere?
Actual Results:  
/etc/alternatives/libwbclient.so.0.15-64: broken symbolic link to /usr/lib64/samba/wbclient/libwbclient.so.0.15
file /etc/alternatives/libwbclient.so.0.15-64 is not owned by any package


Expected Results:  
A valid symlink & appropriate ownershit of a symlink by a package.

Comment 1 Petr Pisar 2023-06-01 14:09:56 UTC
/usr/lib64/samba/wbclient/libwbclient.so.0.15 file was provided by libsmbclient-2:4.17.4-4.fc38.x86_64 package. The file name was changed into /usr/lib64/samba/wbclient/libwbclient.so.0.16 in libwbclient-2:4.18.0-0.2.rc1.fc38.x86_64. I don't know what you aim to do, by I recommend referring to /usr/lib64/samba/wbclient/libwbclient.so.0 file which represents a soname of the library. That file name has not changed.

libwbclient-2:4.18.0-0.2.rc1.fc38.x86_64 binary package is built from samba-4.18.0-0.2.rc1.fc38 source package. Moving to samba component.

Comment 3 Fedora Update System 2023-06-23 09:26:32 UTC
FEDORA-2023-97618afae6 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-97618afae6

Comment 4 Fedora Update System 2023-06-23 10:57:06 UTC
FEDORA-2023-97618afae6 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 5 Fedora Update System 2023-06-23 13:44:09 UTC
FEDORA-2023-ef663b3ec4 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-ef663b3ec4

Comment 6 Fedora Update System 2023-06-24 01:08:44 UTC
FEDORA-2023-ef663b3ec4 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-ef663b3ec4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-ef663b3ec4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2023-06-25 00:50:24 UTC
FEDORA-2023-ef663b3ec4 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 John Dodson 2023-07-14 02:35:35 UTC
Will it be possible in future to select such an errant component?

ie. will libsmbclient be able to be selected as a component?

I ask because the way to find what created a symlink/file is to find it's "owner"
& if that package can't be selected in bugzilla how does the reporter track it
to the actual package (look at dependencies presumably, but that's a bit tedious)


Note You need to log in before you can comment on or make changes to this bug.