Bug 221168 - dbus: Can't send to audit system
dbus: Can't send to audit system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks: 237289
  Show dependency treegraph
 
Reported: 2007-01-02 13:15 EST by Need Real Name
Modified: 2013-03-05 22:48 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.0.2-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-12 15:15:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Start SELinux thread after setuid call. (626 bytes, text/x-patch)
2007-04-02 13:57 EDT, Daniel Walsh
no flags Details

  None (edit)
Description Need Real Name 2007-01-02 13:15:03 EST
Description of problem:
Whenever I update my 'local' policy using 'semodule -i local.pp', I get the
following error in my syslog:

dbus: Can't send to audit system: USER_AVC avc:  received policyload notice
(seqno=5) : exe="/bin/dbus-daemon" (sauid=505, hostname=?, addr=?, terminal=?)
Comment 1 Need Real Name 2007-03-18 09:26:36 EDT
Is this going to be fixed?????
Comment 2 Need Real Name 2007-03-27 20:33:57 EDT
Still haven't heard anything on this whether or not it is meaningful and whether
or not it will be fixed...
Comment 3 Daniel Walsh 2007-03-28 16:19:40 EDT
This seems to be an audit problem.  Audit messages are not being allowed to be
sent if your uid is not 0.
Comment 4 Daniel Walsh 2007-04-02 13:57:28 EDT
Created attachment 151452 [details]
Start SELinux thread after setuid call.
Comment 5 Daniel Walsh 2007-04-02 14:00:37 EDT
Capabilities do not seem to be set cross threads. So if you setuid and retain
certain capabilities after thread creation.  The other threads will not get the
capability.  Moving the creation of the thread after the setuid/capset calls.
gives all threads the capability and the dbus code works.

This patch should be applied to RHEL5/FC6/and devel
Comment 6 Need Real Name 2007-04-11 13:11:52 EDT
Has the patch been applied yet?
Comment 7 David Zeuthen 2007-04-12 15:15:07 EDT
Applied.
Comment 8 Need Real Name 2007-04-13 03:53:03 EDT
I have a fully updated FC6 system and still get the same errors when doing a
'setenforce' operation.

Is a reboot or other service restart required to fix this problem?
Comment 9 Daniel Walsh 2007-04-13 09:44:43 EDT
You need to restart dbus for this to take effect.  The best way to do this is to
reboot, since restarting the messagebus will cause certain desktop apps to blow up.
Comment 10 Need Real Name 2007-04-14 23:44:18 EDT
I still am getting the errors. Is this only patched in rawhide or will it be
backported to FC6?
Comment 11 Steve Grubb 2007-04-15 08:46:35 EDT
I am pretty sure its built only for rawhide at this point. But if the problem is
also in FC6, it should be built there too. The patch is not terribly invasive.
Comment 12 Need Real Name 2007-04-18 18:40:48 EDT
Would be great to see it fixed in FC6 since I noticed and reported this bug back
in January on my FC6 system (I am the original bug poster to this thread so I am
assuming we are talking about the same thing :)

Thanks

Note You need to log in before you can comment on or make changes to this bug.