Bug 221209 - Mail notification summary ignores 'top right'
Mail notification summary ignores 'top right'
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-02 18:10 EST by Bill Case
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 00:52:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Case 2007-01-02 18:10:02 EST
Description of problem:
I like and use the Gnome-mail-notification in my taskbar.  However I
have never been able to get it to do three things.

1) In preferences I gives me the option of choosing the position of the
Summary popup.  I have choosen 'Top Right'.  It never pops up on the top
right.  It seems to be almost at random. It certainly has a keen sense
of where on my screen I am currently working -- and opens there.  For
reasons of habit, I seldom work on the Top Right (others may have other
dead spaces in their viewing range) so I want the Summary to open 'on
top' in the 'top right' hand corner of my screen.

2) On random occasions the width of the Summary is far greater ( more
than double ) the warranted size from the content of the messages.

3) On the Summary and the Tool Tip features I would like to have more
preferences control over the display of 'Mailbox:' (alias should be
availabe rather than the long Mail Box name). 'From:', 'Subject:' and
'Sent:'

By the way, 'Display Test Popup;' always displays on the Top Left even
if another postion was chosen.  The test is not much use if users do not
have a greater choice of what and where the test is displayed.


Version-Release number of selected component (if applicable):
FC6 Gnome 2.16

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thorsten Leemhuis 2007-01-03 00:52:19 EST
mail-notification 4.0 is in the rc-phase (you can rebuild the srpm from devel on
fc6 if you want to try it) and will use libnotify for its popups. So the
behaviour will probably change with it -- maybe its better, maybe it's worse,
we'll see. But upstream is probably unwilling to do further changes to the 3.0
branch as that code is probably obsolete. Closing it as wontfix therefor. Sorry.

I'd suggest you try the 4.0 branch; if there are similar problems it would be
the best if you report it to upstream directly at
https://savannah.nongnu.org/bugs/?group=mailnotify
as the problem is probably not fedora specific. 

Note You need to log in before you can comment on or make changes to this bug.