Bug 221214 - OO Impress dies when adding custom animations
OO Impress dies when adding custom animations
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-02 18:25 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-11 08:04:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example file (880.30 KB, application/vnd.oasis.opendocument.presentation)
2007-01-03 18:32 EST, Paul F. Johnson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 74255 None None None Never

  None (edit)
Description Paul F. Johnson 2007-01-02 18:25:18 EST
Description of problem:
When applying certain types of custom animation to a slide, OO Impress will die

Version-Release number of selected component (if applicable):
2.1.0-6.7

How reproducible:
Depending on the animation depends on if it crashes. Fade in and outs tend to kill

Steps to Reproduce:
1. Create a slide show
2. Add custom animations with flyins and fade in and out
3.
  
Actual results:
(I)    x.org loaded video driver of...
(II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
(II) Reloading /usr/lib64/xorg/modules/drivers/nv_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-48-x86_64 libgcj-4.1.1-48-i386
(V)    kernel is: Linux 2.6.19-1.2891.fc7 #1 SMP Thu Dec 21 10:59:56 EST 2006
x86_64 x86_64 x86_64
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.1.0-6.7-x86_64
(VII)  depth of root window:    24 planes
(VIII) accessibility is: true
(VIV)  fedora release is: Fedora Core release 6 (Rawhide)
...start free space details ...
...end free space details ...
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          permissive
Policy version:                 21
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x19e366c8: /usr/lib64/openoffice.org2.1/program/libuno_sal.so.3 + 0x366c8
0x19e3714b: /usr/lib64/openoffice.org2.1/program/libuno_sal.so.3 + 0x3714b
0x48e0dc80: /lib64/libpthread.so.0 + 0xdc80
0x1be3e79d: /usr/lib64/openoffice.org2.1/program/libbasegfx680lx.so + 0x3e79d
0x1be3e7aa: /usr/lib64/openoffice.org2.1/program/libbasegfx680lx.so + 0x3e7aa
0x1be3fd44: /usr/lib64/openoffice.org2.1/program/libbasegfx680lx.so + 0x3fd44
0x1be402cb: /usr/lib64/openoffice.org2.1/program/libbasegfx680lx.so + 0x402cb
(basegfx::triangulator::triangulate(basegfx::B2DPolyPolygon const&) + 0x9b)
0xbd5a58d4: /usr/lib64/openoffice.org2.1/program/vclcanvas.uno.so + 0x628d4
0xbd57a8d5: /usr/lib64/openoffice.org2.1/program/vclcanvas.uno.so + 0x378d5
0xbd5a0a13: /usr/lib64/openoffice.org2.1/program/vclcanvas.uno.so + 0x5da13
0xbd5a25cc: /usr/lib64/openoffice.org2.1/program/vclcanvas.uno.so + 0x5f5cc
0xbd5a43c6: /usr/lib64/openoffice.org2.1/program/vclcanvas.uno.so + 0x613c6
0xbd5a2d7c: /usr/lib64/openoffice.org2.1/program/vclcanvas.uno.so + 0x5fd7c
0xbd5939b1: /usr/lib64/openoffice.org2.1/program/vclcanvas.uno.so + 0x509b1
0x4182674e: /usr/lib64/openoffice.org2.1/program/libcppcanvas680lx.so + 0x2674e
(cppcanvas::internal::ImplSpriteCanvas::updateScreen(bool) const + 0x1e)
0xbd0745cd: /usr/lib64/openoffice.org2.1/program/slideshow.uno.so + 0xf45cd
0xbd04cb27: /usr/lib64/openoffice.org2.1/program/slideshow.uno.so + 0xccb27
0xbd02ad59: /usr/lib64/openoffice.org2.1/program/slideshow.uno.so + 0xaad59
0xbd0779ad: /usr/lib64/openoffice.org2.1/program/slideshow.uno.so + 0xf79ad
0x4145c1cb: /usr/lib64/openoffice.org2.1/program/libsd680lx.so + 0x45c1cb
0x3a6d2230: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0xd2230
(Timer::ImplTimerCallbackProc() + 0x80)
0xae0504c0: /usr/lib64/openoffice.org2.1/program/libvclplug_gtk680lx.so + 0x164c0
0x15c2d3fb: /lib64/libglib-2.0.so.0 + 0x2d3fb
0x15c2cef4: /lib64/libglib-2.0.so.0 + 0x2cef4 (g_main_context_dispatch + 0x1b4)
0x15c2fd2d: /lib64/libglib-2.0.so.0 + 0x2fd2d
0x15c3025e: /lib64/libglib-2.0.so.0 + 0x3025e (g_main_context_iteration + 0x6e)
0xae051d3b: /usr/lib64/openoffice.org2.1/program/libvclplug_gtk680lx.so + 0x17d3b
0x3a6cc651: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0xcc651
(Application::Yield(bool) + 0x51)
0x3a82d9b0: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0x22d9b0
(Dialog::Execute() + 0x1d0)
0x413ac713: /usr/lib64/openoffice.org2.1/program/libsd680lx.so + 0x3ac713
0x413af824: /usr/lib64/openoffice.org2.1/program/libsd680lx.so + 0x3af824
0x3a8b528b: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0x2b528b
(Control::ImplCallEventListenersAndHandler(unsigned long, Link const&, void*) +
0x7b)
0x3a8a56c8: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0x2a56c8
(Window::EndTracking(unsigned short) + 0x128)
0x3a8a19f0: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0x2a19f0
0x3a8a21f1: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0x2a21f1
0xae077a65: /usr/lib64/openoffice.org2.1/program/libvclplug_gtk680lx.so + 0x3da65
0x3a131bbd: /usr/lib64/libgtk-x11-2.0.so.0 + 0x131bbd
0x1680af3a: /lib64/libgobject-2.0.so.0 + 0xaf3a (g_closure_invoke + 0x10a)
0x1681b18d: /lib64/libgobject-2.0.so.0 + 0x1b18d
0x1681c3bf: /lib64/libgobject-2.0.so.0 + 0x1c3bf (g_signal_emit_valist + 0x61f)
0x1681c7d3: /lib64/libgobject-2.0.so.0 + 0x1c7d3 (g_signal_emit + 0x83)
0x3a22f22e: /usr/lib64/libgtk-x11-2.0.so.0 + 0x22f22e
0x3a12b2ad: /usr/lib64/libgtk-x11-2.0.so.0 + 0x12b2ad (gtk_propagate_event + 0xfd)
0x3a12c2c1: /usr/lib64/libgtk-x11-2.0.so.0 + 0x12c2c1 (gtk_main_do_event + 0x321)
0x39c4661c: /usr/lib64/libgdk-x11-2.0.so.0 + 0x4661c
0x15c2cef4: /lib64/libglib-2.0.so.0 + 0x2cef4 (g_main_context_dispatch + 0x1b4)
0x15c2fd2d: /lib64/libglib-2.0.so.0 + 0x2fd2d
0x15c3025e: /lib64/libglib-2.0.so.0 + 0x3025e (g_main_context_iteration + 0x6e)
0xae051db5: /usr/lib64/openoffice.org2.1/program/libvclplug_gtk680lx.so + 0x17db5
0x3a6cc651: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0xcc651
(Application::Yield(bool) + 0x51)
0x3a6cc6ea: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0xcc6ea
(Application::Execute() + 0x2a)
0x3e62c2f5: /usr/lib64/openoffice.org2.1/program/libsoffice.so + 0x2c2f5
(desktop::Desktop::Main() + 0x15a5)
0x3a6d1ce9: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0xd1ce9
0x3a6d1dd5: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0xd1dd5
(SVMain() + 0x25)
0x3e61eb66: /usr/lib64/openoffice.org2.1/program/libsoffice.so + 0x1eb66
(sal_main + 0x46)
0x4821d924: /lib64/libc.so.6 + 0x1d924 (__libc_start_main + 0xf4)
0x400619: /usr/lib64/openoffice.org2.1/program/simpress.bin + 0x619
...end stackreport details ...
...start sample ldd details ...
...end sample ldd details ...


Expected results:
Should work

Additional info:
Comment 1 Caolan McNamara 2007-01-03 04:15:14 EST
Have you e.g. a sample presentation where this occurs, or a sample presentation
which if I add something specific to it will reproduce this for me ?
Comment 2 Paul F. Johnson 2007-01-03 18:32:55 EST
Created attachment 144755 [details]
Example file

The middle slide I had to play with in PowerPoint and it kills OOo when you run
the presentation (click and the pic should dissolve and the next one appear).

If you add an animation to some of the text and preview it, you can usually get
it to crash by choosing something like peak or fly-in.
Comment 3 Caolan McNamara 2007-01-04 05:26:16 EST
not getting an OOo death on this one with the same x86_64 version yet
Comment 4 Paul F. Johnson 2007-01-06 16:56:52 EST
Try the following URL - kills my copy every time!

http://nodoid.homelinux.org/work/ANNs.ppt - dies at the end with the neuron fade
and appear.
Comment 5 Paul F. Johnson 2007-01-09 18:28:32 EST
Try using a dissolve in - crashes here on the 2.1.0-6.11 version
Comment 6 Caolan McNamara 2007-02-01 10:28:02 EST
Hum ho, now I seem to see something. in 2.2.0. 
Comment 7 Caolan McNamara 2007-02-06 08:11:04 EST
I wonder if you find that 

> export SAL_IGNOREXERRORS=true
> ooimpress troubledoc.ppt

makes any difference ?
Comment 8 Caolan McNamara 2007-02-07 05:34:49 EST
Looks like a depth mismatch on rendering the text into a 32bit pixmap. That fix
will be in 2.2.0-6.2
Comment 9 Paul F. Johnson 2007-02-11 08:04:34 EST
Looks happier now - thanks :-)

Note You need to log in before you can comment on or make changes to this bug.