Bug 221230 - gtk print dialog: No capability to specify that print to file should be B&W output only
gtk print dialog: No capability to specify that print to file should be B&W o...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-02 20:42 EST by Tim Jowers
Modified: 2008-05-06 13:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 13:17:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Jowers 2007-01-02 20:42:48 EST
Description of problem:
"print to file" option no longer exists on printing dialog.
No way to print Black and White postscript files. 

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. Try to print from OO writer
2. Select a B&W printer
3. No checkbox to print to file as in past versions RHEL
  
Actual results:
Cannot print to B&W. LuLu.com Press cannot distribute color PDF through their
printer.

Expected results:
Create B&W PS file.

Additional info:
Tried many other options. Eg.. parallel:/var/out.ps as device and many drivers
including ones known to be for B&W printers. The few which create a PostScript
(such as the Generic PostScript) do not create a B&W file. ps2pdf and other
tools do not convert images to gray AFAICT. Tried numerous options to ps2pdf. 

Went back to an older release but OO Writer has a big bug in that the file
totally reformats even on 2.0.4 from FC5 to 2.0.4 on RHEL4. Arg! Now index and
TOC have to be re-done.

Thanks for any direction!
Comment 1 Tim Waugh 2007-01-03 07:04:07 EST
Fixing component and reassigning.
Comment 2 Caolan McNamara 2007-01-03 07:19:43 EST
A workaround is to select tools->options->general and tick "use openoffice.org
dialogs" in which case you can use the traditional print dialog.

caolanm->mclasen: There just isn't a way for the user to specify that the
generic print to file from the gtk print dialog should be in b&w only.
Comment 3 Matthias Clasen 2007-02-26 14:08:52 EST
The problem here is that cairo does not have a B/W PostScript or PDF surface...
Comment 4 Bug Zapper 2008-04-04 01:28:05 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 5 Bug Zapper 2008-05-06 13:17:26 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.