Bug 221235 - SATA DVDRW hard reset during boot kills the drive
SATA DVDRW hard reset during boot kills the drive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
http://forum.fedoraforum.org/showthre...
:
Depends On:
Blocks: 427887
  Show dependency treegraph
 
Reported: 2007-01-02 23:52 EST by Patrick Hush
Modified: 2008-01-08 12:26 EST (History)
2 users (show)

See Also:
Fixed In Version: Fedora release 7 (Moonshine)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 12:26:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Hush 2007-01-02 23:52:13 EST
Description of problem:When ata5 is probed I get the slow to respond error, it
then sends soft and hard resets and finally gives up, the drive is not seen
after that. If I soft boot into windows the drive is no longer seen either. I
have to power the drive down via a hard boot, then it works in windows again.
Just for fun I pulled the sata cable off during boot up and plugged it back in
after system was up (gotta love hot swappable devices). Because the cable was
unplugged, I did not get the port slow to respond errors. Once I plugged the
drive back in, the hardware was recognized and functional.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:please see dmesg and HW info on forum link.
Comment 1 Patrick Hush 2007-01-04 12:09:30 EST
patched to 2.6.18-1.2869.fc6, problem still persists:
libata version 2.00 loaded.
ata1: SATA max UDMA/133 cmd 0xF883E100 ctl 0x0 bmdma 0x0 irq 225
ata2: SATA max UDMA/133 cmd 0xF883E180 ctl 0x0 bmdma 0x0 irq 225
ata3: SATA max UDMA/133 cmd 0xF883E200 ctl 0x0 bmdma 0x0 irq 225
ata4: SATA max UDMA/133 cmd 0xF883E280 ctl 0x0 bmdma 0x0 irq 225
ata5: SATA max UDMA/133 cmd 0xF883E300 ctl 0x0 bmdma 0x0 irq 225
ata6: SATA max UDMA/133 cmd 0xF883E380 ctl 0x0 bmdma 0x0 irq 225
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata1.00: ATA-7, max UDMA/100, 312581808 sectors: LBA48 NCQ (depth 31/32)
ata1.00: configured for UDMA/100
ata2: SATA link down (SStatus 0 SControl 300)
ata3: SATA link down (SStatus 0 SControl 300)
ata4: SATA link down (SStatus 0 SControl 300)
ata5: softreset failed (1st FIS failed)
ata5: softreset failed, retrying in 5 secs
ata5: port is slow to respond, please be patient
ata5: port failed to respond (30 secs)
ata5: COMRESET failed (device not ready)
ata5: hardreset failed, retrying in 5 secs
ata5: port is slow to respond, please be patient
ata5: port failed to respond (30 secs)
ata5: COMRESET failed (device not ready)
ata5: reset failed, giving up
ata6: SATA link down (SStatus 0 SControl 300)
Comment 2 Jon Stanley 2008-01-07 20:49:09 EST
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Note You need to log in before you can comment on or make changes to this bug.