Bug 221240 - Updating Galeon to 2.0.3-4.fc6.1 is missing a dependency
Summary: Updating Galeon to 2.0.3-4.fc6.1 is missing a dependency
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: galeon
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-03 06:32 UTC by Callum Macdonald
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2007-01-03 19:15:23 UTC


Attachments (Terms of Use)

Description Callum Macdonald 2007-01-03 06:32:51 UTC
Description of problem:
When running yum update to update galeon to version 2.0.3-4.fc6.1, it says it's
missing a dependency (gecko-libs v1.8.0.9 I think). I assumed the dependency was
yet to be updated, so I held off for a few days, but it's been like that for a
week or so now.

Additional info:
I haven't tried disabling other repos to see if that makes a difference. I also
have a few other Mozilla based browsers installed, and have upgraded Firefox to
2.0 using the development repo, so it might be related to that.

Comment 1 Denis Leroy 2007-01-03 19:11:40 UTC
Right, the update matches that of firefox (with which galeon is compiled). What
version of firefox have you installed ? :

> rpm -q --whatprovides gecko-libs
firefox-1.5.0.9-1.fc6
> rpm -q firefox --provides | grep gecko
gecko-libs = 1.8.0.9

Is your yum setup correctly for fedora core updates ? Or maybe are you using a
problematic mirror ?

Comment 2 Denis Leroy 2007-01-03 19:15:23 UTC
Argh, didn't read your post correctly. Yes, you'll need to install galeon from
rawhide as well. I think Remi Collet (http://remi.collet.free.fr/) maintains his
own yum repo with firefox 2.0 and compatible RPMs including galeon if that's any
help.

Closing this as 'not a bug'.



Note You need to log in before you can comment on or make changes to this bug.