This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 221354 - ISE on uploading a null path
ISE on uploading a null path
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Partha Aji
Preethi Thomas
http://rhn.webdev.redhat.com/rhn/syst...
:
Depends On:
Blocks: rhn500h-config-mgmt
  Show dependency treegraph
 
Reported: 2007-01-03 19:27 EST by Partha Aji
Modified: 2007-04-18 13:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 23:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Partha Aji 2007-01-03 19:27:09 EST
Description of problem:
1) Register a system to hosted
2) Provide provisioning to that system
3) Navigate to the SDC Configuration page of that system
4) Click on add files
5) Leave the "File to Upload:" & "Filename/Path:" blank and Select "Upload
Configuration File"

Notice the ISE..
Comment 1 Partha Aji 2007-01-03 19:33:41 EST
com.redhat.rhn.common.db.WrappedSQLException: ORA-01400: cannot insert NULL into
("RHN"."RHNCONFIGFILENAME"."PATH")
ORA-06512: at "RHN.LOOKUP_CONFIG_FILENAME", line 17
ORA-01403: no data found
ORA-06512: at line 1

	at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
	at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:331)
	at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:288)
	at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:743)
	at oracle.jdbc.driver.T4CCallableStatement.doOall8(T4CCallableStatement.java:215)
	at
oracle.jdbc.driver.T4CCallableStatement.executeForRows(T4CCallableStatement.java:954)
	at
oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1168)
	at
oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3285)
	at
oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:3390)
	at
oracle.jdbc.driver.OracleCallableStatement.execute(OracleCallableStatement.java:4223)
	at
net.rkbloom.logdriver.LogCallableStatement.execute(LogCallableStatement.java:148)
	at
com.mchange.v2.c3p0.impl.NewProxyCallableStatement.execute(NewProxyCallableStatement.java:912)
	at
com.redhat.rhn.common.db.NamedPreparedStatement.execute(NamedPreparedStatement.java:111)
	at
com.redhat.rhn.common.db.datasource.CachedStatement.executeCallable(CachedStatement.java:415)
	at com.redhat.rhn.common.db.datasource.CallableMode.execute(CallableMode.java:30)
	at
com.redhat.rhn.domain.config.ConfigurationFactory.lookupConfigFileName(ConfigurationFactory.java:610)
	at
com.redhat.rhn.domain.config.ConfigurationFactory.lookupOrInsertConfigFileName(ConfigurationFactory.java:590)
	at
com.redhat.rhn.manager.configuration.ConfigurationManager.lookupConfigFile(ConfigurationManager.java:1657)
	at
com.redhat.rhn.frontend.action.configuration.BaseAddFilesAction.fileExists(BaseAddFilesAction.java:180)
	at
com.redhat.rhn.frontend.action.configuration.BaseAddFilesAction.execute(BaseAddFilesAction.java:67)
	at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
	... 51 more
Caused by: 
java.sql.SQLException: ORA-01400: cannot insert NULL into
("RHN"."RHNCONFIGFILENAME"."PATH")
ORA-06512: at "RHN.LOOKUP_CONFIG_FILENAME", line 17
ORA-01403: no data found
ORA-06512: at line 1
Comment 2 Grant Gainey 2007-01-17 12:34:18 EST
Retest - BaseAddFiles shouldn't even get as far as fileExists() if there's no
upload specified.  Possibly fixed as of 10-JAN
Comment 3 Partha Aji 2007-02-12 20:43:09 EST
This has now been resolved.. QA - Please make sure you test nulling out other
fields on this page... 
Comment 4 Partha Aji 2007-02-15 17:15:46 EST
Moving to ON_QA
Comment 5 Partha Aji 2007-02-15 17:17:31 EST
Moving to ON_QA
Comment 6 Preethi Thomas 2007-02-16 09:32:21 EST
verified
Comment 7 Preethi Thomas 2007-03-06 16:46:13 EST
verified in stage.
Comment 8 Brandon Perkins 2007-03-12 23:09:17 EDT
Closed in the rhn500h Release.

Note You need to log in before you can comment on or make changes to this bug.