Bug 221359 - Please Update to 0.78.2
Please Update to 0.78.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libcdio (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
http://kwizart.free.fr/fedora/SPECS/l...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-03 20:44 EST by Nicolas Chauvet (kwizart)
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.78.2-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 13:03:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2007-01-03 20:44:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
Please Update to 0.78.2
An up2date version is needed for a package that BuildRequires it to enable:
--enable-cddax
--enable-vcdx

thx
Nicolas (kwizart)

Version-Release number of selected component (if applicable):
libcdio-0.77-3.fc6 

How reproducible:
Always


Steps to Reproduce:
1.Build a package that needs up2date libcdio version.
2.
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Adrian Reber 2007-01-04 07:48:44 EST
Released updates for FC6 and devel.
Comment 2 Adrian Reber 2007-01-05 07:55:24 EST
Why did you reopen this bug? Something wrong with the update?
Comment 3 Nicolas Chauvet (kwizart) 2007-01-05 08:00:22 EST
This issues seems more conplicated!
Here are more informations!

Quick issue:
Don't do the 0.78.2-1 update. Revert back to the 0.77-3 is better for now...
Quick info:
This Security updates of vlc may be link to the bug:
http://www.videolan.org/sa0701.html

The issue:
vlc do not build with licdio 0.78.2 and complain to have up2date version of
libraries involved when Configure enables --enable-cddax and --enable-vcdx...
Quick issues seems to stay with 0.77-3 of libcdio!

How to reproduce:
- Install up2date version of licdio 0.78.2 and libcddb version 1.3 (with their
devel)
you can find rpm for fc6 here : http://kwizart.free.fr/fedora/6/testing/vlc-8_6/
- Try to compile vlc with the options above : --enable-cddax and
--enable-vcdx... (bug appear with x86_32 and x86_64)

Bug comment: vlc sems to bundle is own cdda.h header and use it when appropriate
(include is relative "cdda.h"). But the conflic type appear only if libcdio v
0.78.2 is installed nothing fails with updated libcddb (need to confirm this - i
saw you already ask why the bug has re-open...)

Here is the bug
----
In file included from callback.c:25:
cdda.h:78: error: conflicting types for 'paranoia_mode_t'
/usr/include/cdio/paranoia.h:60: error: previous declaration of
'paranoia_mode_t' was here
make[6]: *** [libcddax_plugin_a-callback.o] Error 1
make[6]: *** Waiting for unfinished jobs....
In file included from access.c:30:
cdda.h:78: error: conflicting types for 'paranoia_mode_t'
/usr/include/cdio/paranoia.h:60: error: previous declaration of
'paranoia_mode_t' was here
access.c: In function 'CDDAReadBlocks':
access.c:225: warning: format '%lld' expects type 'long long int', but argument
8 has type 'int64_t'
access.c:225: warning: format '%lld' expects type 'long long int', but argument
9 has type 'int64_t'
access.c: In function 'CDDARead':
access.c:358: warning: format '%lld' expects type 'long long int', but argument
8 has type 'int64_t'
access.c:358: warning: format '%lld' expects type 'long long int', but argument
9 has type 'int64_t'
access.c: In function 'CDDASeek':
access.c:450: warning: format '%lld' expects type 'long long int', but argument
8 has type 'int64_t'
make[6]: *** [libcddax_plugin_a-access.o] Error 1
make[6]: Leaving directory
`/home/builder/rpmbuild/BUILD/vlc-0.8.6a/modules/access/cdda'
make[5]: *** [all-modules] Error 1
----
Comment 4 Nicolas Chauvet (kwizart) 2007-01-05 08:08:27 EST
I confirm that compilation works fine if libcdio reverts back to 0.77-3 (at
least on x86_64 with --cddax and --svcdx... and with updated libcddb 1.3.0 !)
Comment 5 Adrian Reber 2007-07-23 05:08:51 EDT
I would like to update libcdio to 0.78.2. Are there still problems with vlc?
Comment 6 Nicolas Chauvet (kwizart) 2007-07-23 07:27:28 EDT
Ok just received your patch...
I haven't tested but i suppose it will work...
Do you plan to update it for devel and F-7 FC6 also ?
I plan to rebuild vlc to fix some others bug... So this might be possible...
Comment 7 Adrian Reber 2007-07-23 07:39:13 EDT
I would like to update it first for the devel branch to see if nothing really
breaks. If that works without problems I would update F-7. I would rather not
touch FC6 if that is okay for you.
The update should not break anything because (as far as i can see) there no ABI
breakage.
I will update it pretty soon now on devel and you can then, as soon it is
available, try to build vlc against devel. Please let me know if it works and
then I will continue with F-7.
Comment 8 Nicolas Chauvet (kwizart) 2007-07-26 21:00:54 EDT
I've tested with my own version of libcdio 0.78.2 and it build fine..
(the patch you submited to me was send to vlc-devel if this was not ever done...)

Well, i would prefer to have this update for all Fedora that are still alive...
this would be easier for me than not to have a special conditionnals as this
patch will bring some api diff between branches...

Then you could build it at least for Fedora 7 testing... i've already adviced
the mplayer maintainer (Rathann) for that...
Comment 9 Fedora Update System 2007-07-27 01:50:16 EDT
libcdio-0.78.2-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Adrian Reber 2007-07-27 03:32:27 EDT
I will also update FC-6. No problem.
Comment 11 Fedora Update System 2007-07-30 13:03:06 EDT
libcdio-0.78.2-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.