Bug 221362 - edquota -p no longer resets grace time
edquota -p no longer resets grace time
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: quota (Show other bugs)
4.4
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Novotny
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-03 21:42 EST by Ian Mortimer
Modified: 2010-03-22 17:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-22 09:46:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Mortimer 2007-01-03 21:42:03 EST
Description of problem:
In previous releases it was possible to reset an over quota grace time with
either of these commands

   edquota -p $u $u

   setquota -p $u -u $u -a

This no longer works in the current version.
   
Version-Release number of selected component (if applicable):
quota-3.12-5


How reproducible:
always

Steps to Reproduce:
1. set up a file system with quotas
2. put an account over quota and wait for the grace period to run down
3. run one of the above commands for the account
  
Actual results:
grace period doesn't change


Expected results:
with previous versions of quota the grace period was reset and the quotas unchanged.


Additional info:
While this is not a major bug it was the simplest way I could find to extend the
grace time without changing the quota.
Comment 1 Ondrej Vasik 2010-03-22 09:46:41 EDT
Thanks for reporting the issue. Problem seems to be fixed in RHEL-5 (not reproducible) - even the RHEL-4 quota sources seems to be working the expected way on our machine - maybe it was kernel issue (and fixed now) or something configuration related. 

Anyway, as RHEL-4.9 is last update for RHEL-4 and it is not suitable for new features and should address only security, performance and critical issues, I'm closing that bugzilla WONTFIX.
Comment 2 Ian Mortimer 2010-03-22 17:55:17 EDT
It works fine now on our el4 file server also so not configuration related.


Thanks
--
Ian

Note You need to log in before you can comment on or make changes to this bug.