Bug 221383 - [kn_IN] GSUB combinations has problem with Ra
[kn_IN] GSUB combinations has problem with Ra
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lohit-fonts (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rahul Bhalerao
: i18n
Depends On: 219784
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 05:58 EST by Parag Nemade
Modified: 2009-05-27 18:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 18:40:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tested Image (96.91 KB, image/png)
2007-04-28 07:42 EDT, A S Alam
no flags Details
latest test cases (233.87 KB, image/png)
2008-01-18 05:41 EST, Shankar Prasad
no flags Details

  None (edit)
Description Parag Nemade 2007-01-04 05:58:30 EST
+++ This bug was initially created as a clone of Bug #219784 +++

Description of problem:
Kannada fonts having problem with following combination in Test Case
ra+halant+ka is shown as 'ka+halant+ra'

Version-Release number of selected component (if applicable):
fonts-kannada-2.0.11-1.fc7

How reproducible:
Evertime

Steps to Reproduce:
1. open combination in Gedit
2.
3.
  
----------------
 U+0CB0 U+0CCD U+0C95  ರ್ಕ  RA + HALANT + KA			
U+0CB0 U+0CCD U+0C96 ರ್ಖ RA + HALANT + KHA			
U+0CB0 U+0CCD U+0C97 ರ್ಗ RA + HALANT + GA			
U+0CB0 U+0CCD U+0C98 ರ್ಘ RA + HALANT + GHA			
U+0CB0 U+0CCD U+0C99 ರ್ಙ RA + HALANT + NGA			
U+0CB0 U+0CCD U+0C9A ರ್ಚ RA + HALANT + CA			
U+0CB0 U+0CCD U+0C9B ರ್ಛ RA + HALANT + CHA			
U+0CB0 U+0CCD U+0C9C ರ್ಜ RA + HALANT + JA			
U+0CB0 U+0CCD U+0C9D ರ್ಝ RA + HALANT + JHA			
U+0CB0 U+0CCD U+0C9E ರ್ಞ RA + HALANT + NNA			
U+0CB0 U+0CCD U+0C9F ರ್ಟ RA + HALANT + TTA			
U+0CB0 U+0CCD U+0CA0 ರ್ಠ RA + HALANT + TTHA			
U+0CB0 U+0CCD U+0CA1 ರ್ಡ RA + HALANT + DDA			
U+0CB0 U+0CCD U+0CA2 ರ್ಢ RA + HALANT + DDHA			
U+0CB0 U+0CCD U+0CA3 ರ್ಣ RA + HALANT + NNA			
U+0CB0 U+0CCD U+0CA4 ರ್ತ RA + HALANT + TA			
U+0CB0 U+0CCD U+0CA5 ರ್ಥ RA + HALANT + THA			
U+0CB0 U+0CCD U+0CA6 ರ್ದ RA + HALANT + DA			
U+0CB0 U+0CCD U+0CA7 ರ್ಧ RA + HALANT + DHA			
U+0CB0 U+0CCD U+0CA8 ರ್ನ RA + HALANT + NA			
U+0CB0 U+0CCD U+0CAA ರ್ಪ RA + HALANT + PA			
U+0CB0 U+0CCD U+0CAB ರ್ಫ RA + HALANT + PHA			
U+0CB0 U+0CCD U+0CAC ರ್ಬ RA + HALANT + BA			
U+0CB0 U+0CCD U+0CAD ರ್ಭ RA + HALANT + BHA			
U+0CB0 U+0CCD U+0CAE ರ್ಮ RA + HALANT + MA			
U+0CB0 U+0CCD U+0CAF ರ್ಯ RA + HALANT + YA			
U+0CB0 U+0CCD U+0CB0 ರ್ರ RA + HALANT + RA			
U+0CB0 U+0CCD U+0CB2 ರ್ಲ RA + HALANT + LA			
U+0CB0 U+0CCD U+0CB3 ರ್ಳ RA + HALANT + LLA			
U+0CB0 U+0CCD U+0CB5 ರ್ವ RA + HALANT + VA			
U+0CB0 U+0CCD U+0CB6 ರ್ಶ RA + HALANT + SHA			
U+0CB0 U+0CCD U+0CB7 ರ್ಷ RA + HALANT + SSA			
U+0CB0 U+0CCD U+0CB8 ರ್ಸ RA + HALANT + SA
U+0CB0 U+0CCD U+0CB9  ರ್ಹ  RA + HALANT + HA
----------------
Comment 1 Liang Zhang 2007-01-22 21:09:58 EST
This is a bug of fonts-indic, not a bug of pango.
Comment 2 Liang Zhang 2007-01-24 03:33:17 EST
sorry, this is a bug of pango.
Comment 3 Liang Zhang 2007-02-13 21:49:14 EST
It is a problem about ordering of indic module of pango.
Comment 4 Parag Nemade 2007-03-02 07:00:25 EST
this is problem because of wrong ligature rule for rphf form.
Comment 5 Parag Nemade 2007-03-07 01:49:20 EST
Fix built in fonts-indic-2.1.4
Comment 6 A S Alam 2007-04-28 07:42:50 EDT
Created attachment 153702 [details]
Tested Image

Nothing seems fixed, Image is just Example
it is tested with following:
Firefox (font test Case)
fonts-kannada-2.1.5-1.fc7
pango-1.16.2-1.fc7
Comment 7 A S Alam 2007-04-28 07:44:20 EDT
Assigned back with comment #6
Comment 8 A S Alam 2007-04-30 02:49:51 EDT
hi svenkate,
can you please make comment about Image and Render fonts
Comment 9 Rahul Bhalerao 2008-01-17 08:38:27 EST
I think the test cases are not correct, bug has been fixed according to the
inputs given by Shankar. 
Shankar, can you please confirm the bug fix?
Comment 10 Shankar Prasad 2008-01-18 05:41:28 EST
Created attachment 292121 [details]
latest test cases

Yes the test cases shown in the attachment(Comment #6) is not correct. I think
the  latest test cases (shown in the attachment) will show the correct result.
Comment 11 Bug Zapper 2008-05-13 22:32:15 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Tony Fu 2008-09-09 23:17:07 EDT
requested by Jens Petersen (#27995)
Comment 13 Jens Petersen 2009-05-27 18:40:40 EDT
Closing - please reopen if there should still be any problem.

Note You need to log in before you can comment on or make changes to this bug.