Bug 221491 - [a11y] OOo writer crash with Word document, but not always
[a11y] OOo writer crash with Word document, but not always
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 15:15 EST by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.1.0-6.12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 10:45:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File in which it crashed (1015.50 KB, application/msword)
2007-01-04 15:15 EST, Horst H. von Brand
no flags Details
Crash report from OOo writer (4.04 KB, text/plain)
2007-01-04 15:16 EST, Horst H. von Brand
no flags Details
mapped stack (3.57 KB, text/plain)
2007-01-05 06:05 EST, Caolan McNamara
no flags Details
valgrind output (1.98 KB, text/plain)
2007-01-06 09:55 EST, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 73201 None None None Never

  None (edit)
Description Horst H. von Brand 2007-01-04 15:15:53 EST
Description of problem:
OOo  crashed when paging rapidly (via slider) through an Microsoft Office document

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.1.0-6.7

How reproducible:
Happened once, looking at the document earlier (or other documents for that
matter) worked fine (modulo chattiness)

Steps to Reproduce:
1. Opened attached document, several times in succession
2. Via slider went to page 60 or so
3.
  
Actual results:
Atached crash report

Expected results:


Additional info:
Comment 1 Horst H. von Brand 2007-01-04 15:15:54 EST
Created attachment 144835 [details]
File in which it crashed
Comment 2 Horst H. von Brand 2007-01-04 15:16:46 EST
Created attachment 144836 [details]
Crash report from OOo writer
Comment 3 Caolan McNamara 2007-01-05 06:05:23 EST
Created attachment 144899 [details]
mapped stack

I can't reproduce this yet, but here's the mapped stack
Comment 4 Caolan McNamara 2007-01-05 06:14:38 EST
This is *something* to do with accessibility, but I can't reproduce it under
GNOME with a11y enabled. And the final couple of frames look ok. Any idea as to
how exactly to get this to happen. I've been scrolling up and down a few times
without failure
Comment 5 Horst H. von Brand 2007-01-05 08:25:52 EST
I've got this just once, sorry. Only strange things I did was to open (and
close) oowriter with 3 or 4 files, and reopen it shortly after several times,
then scrolling down fast as I wanted to look at near the end of the file again.
Comment 6 Caolan McNamara 2007-01-05 09:51:26 EST
rats, these sometimes happens bugs are the worst. I'll valgrind scrolling around
this doc and see if anything pops up
Comment 7 Caolan McNamara 2007-01-06 09:55:02 EST
Created attachment 144970 [details]
valgrind output

valgrind found something in the crash area, that looks like the problem
Comment 8 Caolan McNamara 2007-01-06 10:05:13 EST
gotcha, fix checked in and submitted upstream. Will be in >= 2.1.0-6.11
Comment 9 Caolan McNamara 2007-01-15 10:45:54 EST
Should be good in rawhide now with openoffice.org-2.1.0-6.12

Note You need to log in before you can comment on or make changes to this bug.