Bug 221499 - mouse grab of title bar loses grab and pointer snaps away from window
mouse grab of title bar loses grab and pointer snaps away from window
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: beryl-core (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 15:33 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.1.9999.2-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 21:52:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (4.71 KB, text/plain)
2007-01-08 19:23 EST, John Ellson
no flags Details

  None (edit)
Description John Ellson 2007-01-04 15:33:30 EST
Description of problem:
Often, when using the mouse to grab the title bar of a window to drag it across
the screen, the window moves a little then the mouse seems to lose the grab and
the points snaps to some distance away from teh original grab point, but still
dragging the window.   This just started happening today so I think the bug has
been recently introduced.  The same problem occurs with all of the window
decorators.  The same problem does not occur with metacity.

Version-Release number of selected component (if applicable):
beryl-core-0.1.4-1.fc7

How reproducible:
Most window grab&drags

Steps to Reproduce:
1.Press Button-1 over title bar of a window
2.drag window around screen
3.
  
Actual results:
pointer snaps away from window

Expected results:
mouse pointer should remain at grab poisition on wiondow during drag

Additional info:
Comment 1 Jarod Wilson 2007-01-08 17:41:14 EST
Hrm, what sort of xorg.conf do you have? I'm unable to reproduce this bug,
window dragging is working as expected here. Also, does this happen with compiz
as well (enabled via "Desktop Effects" item on System->Preferences menu), or
only beryl?
Comment 2 John Ellson 2007-01-08 19:23:22 EST
Created attachment 145124 [details]
xorg.conf
Comment 3 John Ellson 2007-01-08 19:25:57 EST
Can't reproduce the problem using compiz with a couple of minutes of dragging
windows around.  Switching back to beryl and the problem occurs immediately on
first drag.

xorg.conf attached in Comment #2.
Comment 4 Jarod Wilson 2007-01-11 11:47:56 EST
Hrm, your config looks pretty similar to the one I've got here, though I don't
have anything for these three:

    Option         "NvAGP" "True"
    Option         "HWCursor" "True"
    Option         "CursorShadow" "True"

Maybe try with those off, see if there's any difference? Also, what driver
version is this with? I'm running 1.0-9746...
Comment 5 John Ellson 2007-01-11 12:30:18 EST
I'm also running 1.0-9746.    I have no i386 rpms on my system so I'm definitely 
running 64bit binaries.

Turning those options off didn't change this problem, but it did momentarily
introduce some nasty block artifacts around the pointer.  Also the pointer would
just disappear at times, but still worked if you could guess where it was.

I have a GeForce 7800 GT with 256MB on PCI Express 16X
Comment 6 Jarod Wilson 2007-01-30 11:32:37 EST
Please see if you can reproduce this with the 0.1.99.2 packages built yesterday...
Comment 7 Jarod Wilson 2007-02-05 16:45:31 EST
...or with the 0.1.9999.1 packages built today.
Comment 8 John Ellson 2007-03-14 19:32:39 EDT
Sorry, my system was down for repairs...

I cannot reproduce this problem with beryl-0.1.9999.2-2.fc7.x86_64

Seems that bug is fixed.   Thanks.

Comment 9 Jarod Wilson 2007-03-14 21:52:24 EDT
Cool, happy to hear it.

Note You need to log in before you can comment on or make changes to this bug.