Bug 221541 - [DOCUMENTATION] Please update guidelines given in the Install Guide for Fedora Core 6 and JRE 6
[DOCUMENTATION] Please update guidelines given in the Install Guide for Fedor...
Status: CLOSED CANTFIX
Product: 389
Classification: Community
Component: wiki (Show other bugs)
1.0.4
All Linux
medium Severity high
: ---
: ---
Assigned To: Rich Megginson
To Ngan
http://directory.fedora.redhat.com/wi...
:
Depends On:
Blocks: FDS1.1.0
  Show dependency treegraph
 
Reported: 2007-01-04 18:53 EST by Răzvan Sandu
Modified: 2008-01-03 12:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-23 17:07:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2007-01-04 18:53:45 EST
Description of problem:


Hello,

Guidelines given in the Install Guide (especially regarding Java support) seems
to refer to much older versions of Fedora Core and Java JRE.

This is also the case with the instructions kindly provided by Paul at
http://fedoranews.org/mediawiki/index.php/JPackage_Java_for_FC4


Please note that the most recent branch of Sun's Java JRE is 6 - the native
implementation of Java wasn't recently put under GPL by Sun ?

The RPM package of Sun's "Java Runtime Environment (JRE) 6" p(or even JRE 5
Update 10) provided at http://java.sun.com/javase/downloads/index.jsp won't
install directly on Fedora Core 6, since many file conflicts with Fedora's
native implementation of Java.


Regards,
Razvan

Version-Release number of selected component (if applicable):
fedora-ds-1.0.4-1.FC6.i386


How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The provided procedures won't work (unmodified) on Fedora Core 6 and with Java
JRE 6.

Expected results:
Please upgrade the procedures accordingly or provide a link to some newer
third-party documentation.

Additional info:
Comment 1 Rich Megginson 2007-01-09 17:36:38 EST
I don't think this is a Fedora DS bug.  It sounds like a bug in the Sun RPM
packaging.
Comment 2 Răzvan Sandu 2007-01-10 03:04:36 EST
Hello and many thanks,


Here is how this can be easily reproduced:

1. Install a fresh Fedora Core 6, with default options.
2. Apply all online updates via yum.
3. Go to http://java.sun.com/javase/downloads/index.jsp
4. Choose the "Java Runtime Environment (JRE) 6" section.
5. Press Download.
6. In the next page, accept the license and download the file named "Linux RPM
in self-extracting file". It will download a .bin file.
7. On the local system, as root, give the .bin file permissions for execution
(x) and run it. It will unpack, extracting a .rpm file with the same name.
8. Try to install the rpm file using the standard "rpm -ivh" command.

The installation will fail, apparently because it conflicts with the native Java
implementation in Fedora.

This is a pretty hard obstacle in smoothly installation and usage of Fedora
Directory Server.

Regards,
Razvan
Comment 3 Răzvan Sandu 2007-01-10 07:13:42 EST
Hello,


I've managed to perform the steps described in comment#2 (sorry for the above,
it seems first time I didn't use a 100% fresh installation of FC6, but one
upgraded from FC5 !).

Both JRE 6 and fedora-ds-1.0.4 RPMs installed OK.

However, when I did a /usr/sbin/alternatives --config java to switch between
java implementations (as instructed in 

http://fedoranews.org/mediawiki/index.php/JPackage_Java_for_FC4)

I get this:

There is 1 program that provides 'java'.

  Selection    Command
-----------------------------------------------
*+ 1           /usr/lib/jvm/jre-1.4.2-gcj/bin/java

Enter to keep the current selection[+], or type selection number: 


It seems alternatives only "sees" the java implementation built-in in Fedora, so
the switch is impossible.

If there is a different procedure for FC6, FC-DS 1.0.4 and JRE 6, would you
please put in in documentation ?


Regards,
Răzvan
Comment 4 Rich Megginson 2007-01-10 09:09:42 EST
I can appreciate your difficulty.  However, the actual solution to and
documentation of this problem are outside the scope of Fedora Directory Server.
 It more properly falls into the domain of the Fedora OS or jpackage.org.   
However, I added some text to the Install_Guide to state the difficulties with
Java 6 and FC-6 that you encountered.

I suggest using Sun or IBM Java 1.4 or 1.5 which should work just fine.
Comment 5 Răzvan Sandu 2007-01-10 09:35:41 EST
Hello again,

Related to this, installing the above RPM file for JRE 6 also have "stolen" a
file association: OpenDocument Spreasheet files on my system (.ods) became "Java
archives" and double-clicking them doesn't open with OpenOffice.org Calc.

Temporarily, I solved this by deinstalling JRE  :-(


Regards,
Răzvan

Note You need to log in before you can comment on or make changes to this bug.