Bug 221555 - evolution-sharp installs mono libraries to the wrong directory
evolution-sharp installs mono libraries to the wrong directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-sharp (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 22:33 EST by Toshio Kuratomi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: evolution-sharp-0.12.1-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-05 10:36:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Kuratomi 2007-01-04 22:33:50 EST
Description of problem:
Since FC6, mono libraries belong in %{_libdir} rather than /usr/lib.
The recent build of evolution-sharp-0.12.1-1.fc7 changes the library's install
path to /usr/lib.

Version-Release number of selected component (if applicable):
evolution-sharp-0.12.1-1.fc7

How reproducible:
Every time I install it :-)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Barnes 2007-01-04 22:40:24 EST
This was changed upstream for evolution-sharp-0.12.1:

2006-11-20  Daniel Drake  <dsd@gentoo.org>

        * evolution/Makefile.am: mono packages are supposedly arch-independent,
        install assembly into $(prefix)/lib rather than $(libdir)

This needs to be reverted then for Fedora Core?
Comment 2 Yanko Kaneti 2007-01-04 22:52:00 EST
Rather reverted upstream. Its not the place to hardcode any of this stuff. Is it?
Comment 3 Toshio Kuratomi 2007-01-05 02:24:36 EST
Yes it should be reverted.

Probably reverted for Fedora only but only alexl can tell you for sure (as I
don't know whether upstream monr was interested in out mono-in-libdir changes.)
 There are a few mono apps where upstream places their libraries in libdir but
most place them in %{_prefix}/lib and we have to do a little patching (build
scripts sometimes, pkgconfig files).

Here's the bug where we discussed various places that mono could be located and
finally settled on %{_libdir}.
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=185690
Comment 4 Matthew Barnes 2007-01-05 10:36:57 EST
evolution-sharp-0.12.1-2.fc7 reverses this upstream change:

http://svn.gnome.org/viewcvs/evolution-sharp/trunk/evolution/Makefile.am?rev=124&r1=123&r2=124

Note You need to log in before you can comment on or make changes to this bug.