Bug 221610 - cifs-mount problem / kernel hang
cifs-mount problem / kernel hang
Status: CLOSED DUPLICATE of bug 214622
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-05 11:53 EST by Bjoern Robbe
Modified: 2014-06-18 03:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 06:51:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bjoern Robbe 2007-01-05 11:53:16 EST
Description of problem:

if I mount shares with cifs 

mount -t cifs -o rw,users,uid=xxx,gid=xxx,credentials=/home/xxx/zzz //AAA/a /BBB/b 

the complete system hangs periodicly.

Version-Release number of selected component (if applicable):

Kernel Version 
2.6.18-1.2200.fc5smp and 2.6.18-1.2239.fc5smp

How reproducible:

I don't know; mount serveral times and the system dies.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Dec  6 11:07:00 xxx kernel: ------------[ cut here ]------------
Dec  6 11:07:00 xxx kernel: kernel BUG at lib/list_debug.c:65!
Dec  6 11:07:00 xxx kernel: invalid opcode: 0000 [#1]
Dec  6 11:07:00 xxx kernel: SMP
Dec  6 11:07:00 xxx kernel: last sysfs file:
/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
Dec  6 11:07:00 xxx kernel: Modules linked in: nls_utf8 cifs nfsd exportfs lockd
nfs_acl ppdev autofs4 hidp rfcomm l2cap bluetooth vmnet(U) vmmon(U)
 sunrpc video sbs ibm_acpi i2c_ec dock button battery asus_acpi ac ipv6 lp
parport_pc parport snd_hda_intel snd_hda_codec snd_seq_dummy snd_seq_oss ohci139
4 joydev snd_seq_midi_event ieee1394 ipw3945(U) snd_seq sg snd_seq_device tg3
ieee80211(U) ieee80211_crypt(U) serio_raw snd_pcm_oss snd_mixer_oss snd_pcm s
nd_timer snd uhci_hcd ide_cd i2c_i801 soundcore ehci_hcd cdrom snd_page_alloc
i2c_core pcspkr dm_snapshot dm_zero dm_mirror dm_mod ext3 jbd ahci libata sd_
mod scsi_mod
Dec  6 11:07:00 xxx kernel: CPU:    0
Dec  6 11:07:00 xxx kernel: EIP:    0060:[<c04e84e7>]    Tainted: PF     VLI
Dec  6 11:07:00 xxx kernel: EFLAGS: 00010096   (2.6.18-1.2200.fc5smp #1)
Dec  6 11:07:00 xxx kernel: EIP is at list_del+0x23/0x6c
Dec  6 11:07:00 xxx kernel: eax: 00000048   ebx: e1e86420   ecx: c06789d0   edx:
00000096
Dec  6 11:07:00 xxx kernel: esi: f746a840   edi: eb8ac000   ebp: c23dfac0   esp:
f7fefef8
Dec  6 11:07:00 xxx kernel: ds: 007b   es: 007b   ss: 0068
Dec  6 11:07:00 xxx kernel: Process events/0 (pid: 8, ti=f7fef000 task=c21405e0
task.ti=f7fef000)
Dec  6 11:07:00 xxx kernel: Stack: c063d458 e1e86420 00000000 e1e86420 c046a3e5
c0740fc8 00000002 f746a960
Dec  6 11:07:00 xxx kernel:        00000000 f746a960 00000002 f746a940 00000000
c046a4e3 00000000 00000000
Dec  6 11:07:00 xxx kernel:        c23dfac0 f746a864 f746a840 c23dfac0 c2148b40
00000282 c046b919 00000000
Dec  6 11:07:00 xxx kernel: Call Trace:
Dec  6 11:07:00 xxx kernel:  [<c046a3e5>] free_block+0x68/0xdc
Dec  6 11:07:00 xxx kernel:  [<c046a4e3>] drain_array+0x8a/0xb5
Dec  6 11:07:00 xxx kernel:  [<c046b919>] cache_reap+0x53/0x117
Dec  6 11:07:00 xxx kernel:  [<c04340ef>] run_workqueue+0x86/0xc6
Dec  6 11:07:01 xxx kernel:  [<c04349dd>] worker_thread+0xd9/0x10c
Dec  6 11:07:01 xxx kernel:  [<c0436eb3>] kthread+0xc0/0xed
Dec  6 11:07:01 xxx kernel:  [<c0404ccb>] kernel_thread_helper+0x7/0x10
Dec  6 11:07:01 xxx kernel: DWARF2 unwinder stuck at kernel_thread_helper+0x7/0x10
Dec  6 11:07:01 xxx kernel: Leftover inexact backtrace:
Dec  6 11:07:01 xxx kernel:  =======================
Dec  6 11:07:01 xxx kernel: Code: 00 00 89 c3 eb e8 90 90 53 89 c3 83 ec 0c 8b
40 04 8b 00 39 d8 74 1c 89 5c 24 04 89 44 24 08 c7 04 24 58 d4 63 c0
e8 ab d7 f3 ff <0f> 0b 41 00 95 d4 63 c0 8b 03 8b 40 04 39 d8 74 1c 89 5c 24 04
Dec  6 11:07:01 xxx kernel: EIP: [<c04e84e7>] list_del+0x23/0x6c SS:ESP
0068:f7fefef8
Dec  6 11:07:01 xxx kernel:  <3>BUG: sleeping function called from invalid
context at kernel/rwsem.c:20
Dec  6 11:07:01 xxx kernel: in_atomic():0, irqs_disabled():1
Dec  6 11:07:01 xxx kernel:  [<c04050ef>] dump_trace+0x69/0x1af
Dec  6 11:07:01 xxx kernel:  [<c040524d>] show_trace_log_lvl+0x18/0x2c
Dec  6 11:07:01 xxx kernel:  [<c0405800>] show_trace+0xf/0x11
Dec  6 11:07:01 xxx kernel:  [<c04058fa>] dump_stack+0x15/0x17
Dec  6 11:07:01 xxx kernel:  [<c04398a6>] down_read+0x12/0x20
Dec  6 11:07:01 xxx kernel:  [<c0431adf>] blocking_notifier_call_chain+0xe/0x29
Dec  6 11:07:01 xxx kernel:  [<c0427b14>] do_exit+0x1b/0x776
Dec  6 11:07:01 xxx kernel:  [<c04057a1>] die+0x29d/0x2c2
Dec  6 11:07:01 xxx kernel:  [<c0405ee3>] do_invalid_op+0xa2/0xab
Dec  6 11:07:01 xxx kernel:  [<c0404aa5>] error_code+0x39/0x40
Dec  6 11:07:01 xxx kernel: DWARF2 unwinder stuck at error_code+0x39/0x40
Dec  6 11:07:01 xxx kernel: Leftover inexact backtrace:
Dec  6 11:07:01 xxx kernel:  [<c04e84e7>] list_del+0x23/0x6c
Dec  6 11:07:01 xxx kernel:  [<c046a3e5>] free_block+0x68/0xdc
Dec  6 11:07:01 xxx kernel:  [<c046a4e3>] drain_array+0x8a/0xb5
Dec  6 11:07:01 xxx kernel:  [<c046b919>] cache_reap+0x53/0x117
Dec  6 11:07:01 xxx kernel:  [<c04340ef>] run_workqueue+0x86/0xc6
Comment 1 Jeff Layton 2007-11-18 07:58:37 EST
Is this still an issue with more recent fedora releases? Particularly F7 or F8?
Comment 2 Jeff Layton 2008-01-15 06:51:26 EST
I believe this is an already-fixed memory corruption bug. Closing as a dupe of
214622.


*** This bug has been marked as a duplicate of 214622 ***

Note You need to log in before you can comment on or make changes to this bug.