Bug 221674 - Installation on Toshiba Tecra 8200 loops
Installation on Toshiba Tecra 8200 loops
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Depends On:
  Show dependency treegraph
Reported: 2007-01-05 18:21 EST by Göran Uddeborg
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-09 08:47:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2007-01-05 18:21:21 EST
Description of problem:
I'm trying to install FC6 on an Toshiba Tecra 8200.  The installation seems to
start normally.  Because of the small memory it uses text mode installation, and
activates swap during installation, but otherwise nothing in particular.

But after installing some packages, nothing more happens.  It happens in
different places, but it often happens around glibc-common.  Sometimes it gets
further, and hangs at festival.

Switching to the shell in virtual terminal 2 I see that anaconda is spinning,
using all the CPU.  But even if I wait very long, it doesn't get further.

I'm not sure this is an anaconda bug.  I chose that component since I see
anaconda behave strangely.  But it could of course be something else anaconda
depends on, like the kernel, which makes anaconda go into some loop.

I've tried to install from CD, and to boot from CD but install over FTP, with
the same result.  The installation CD does pass mediacheck.

Version-Release number of selected component (if applicable):
FC6 distribution image.
Comment 1 David Cantrell 2007-01-08 22:08:48 EST
How much memory do you have?  If it's less than 256MB (which would force text
mode), I'd suggest unchecking *ALL* package groups that are flagged.  What will
happen is the base set of things will get installed and then you can boot up
after that and use yum to install other things.
Comment 2 Göran Uddeborg 2007-01-09 05:34:46 EST
The machine has only 128 MB.

Unchecking everything didn't help though.  It hang at glibc-common in that case
too, and I guess is pretty hard to avoid THAT package.

If it is a memory issue, I can imagine the build-locale-archive job which is run
in the postinstall of glibc-common influences this.  But why would anaconda fail
with small physical memory?  I mean, swap is activated, so the total virtual
memory should be enough.  (I see with "free" that some, but not very much, swap
space is used.)  What is it in anaconda that requires real physical memory?

I tried to install FC5, and that worked fine.  So I guess upgrading with yum
from there could be a workaround.  (Though I'm still curious why anaconda needs
physical memory.)
Comment 3 David Cantrell 2007-01-09 08:47:32 EST
It's not anaconda that's failing, it's yum and rpm in the backend that need
large amounts of room to work.

256MB is the minimum required to install FC6.  Doing a yum upgrade from FC5 will
probably work fine for you, though it is annoying.

Closing this as CANTFIX since there's not really anything I can do about it for
FC-6.  Reducing the runtime memory requirements of yum and rpm is a goal, but
I'm not sure how much they can be reduced.
Comment 4 Göran Uddeborg 2007-01-09 12:08:58 EST
I see.  I'll do a "manual" upgrade with yum.

But why isn't virtual memory good enough?  Swap space is nowhere near being
Comment 5 David Cantrell 2007-01-09 15:17:26 EST
The required resident size is larger than 128M, so swap doesn't matter much in
this case.  Some architectures it works on because the package depsolving phase
doesn't creep over 128M.
Comment 6 Göran Uddeborg 2007-01-11 10:18:37 EST
Ok.  I thought processes typically were not even aware if parts were paged out
or not.  But I guess anaconda does something very special.

FWIW we made a virtual (VMWare) machine with only 96 MB memory.  That one DID
install FC6 fine, although it had even less physical memory tna my laptop.  It
was doing a lot of swapping from time to time, but it never hang.

Note You need to log in before you can comment on or make changes to this bug.