Bug 221687 - Busy wait cursor missing in beryl
Busy wait cursor missing in beryl
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: beryl-core (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-06 00:41 EST by Michael Hampton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-02 09:29:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.15 KB, text/plain)
2007-01-06 00:41 EST, Michael Hampton
no flags Details

  None (edit)
Description Michael Hampton 2007-01-06 00:41:51 EST
Description of problem:

When using beryl as window manager, the busy wait cursor does not appear when
the system is busy.

Version-Release number of selected component (if applicable):

beryl-core-0.1.4-2.fc6

How reproducible:

Always

Steps to Reproduce:
1. # yum install beryl-gnome
2. $ beryl-manager
3. Set beryl as window manager
4. Start any application. (Alternately, open Firefox and load a page.)
  
Actual results:

Cursor disappears while system is busy. (Alternately, cursor disappears while
Firefox is loading a page.) Arrow cursor reappears when system is no longer busy.

Expected results:

Busy wait cursor should appear while system is busy.

Additional info:
Comment 1 Michael Hampton 2007-01-06 00:41:52 EST
Created attachment 144959 [details]
xorg.conf
Comment 2 Jarod Wilson 2007-01-08 13:33:08 EST
I'm unable to reproduce this bug on my test system here, the cursor shows up as
expected. I'd suggest lobbying upstream for assistance, I'm afraid I'm mostly
just a packager and I dunno how to trouble-shoot this one.
Comment 3 Michael Hampton 2007-01-08 14:05:55 EST
Thanks for the reminder. After a whole lot of experimentation, I got the cursors
back by adding the following to the Device section of xorg.conf:

Option "HWCursor" "on"

I would think that cursors wouldn't just appear and disappear without that
option, but what do I know? And after a whole lot of searching, I'd guess that
it is an upstream issue, since people seem to be having the same trouble on
other distributions.
Comment 4 Jarod Wilson 2007-01-08 15:06:03 EST
Could also be something specific to using nvidia drivers, which we don't
technically support -- though my test box that doesn't have the problem is also
using them...

But yes, most likely an upstream beryl bug. There are quite a few of those,
seemingly with equal numbers of fixes and new ones every release. :)
Comment 5 Jarod Wilson 2007-02-01 17:09:56 EST
Please retest w/the latest beryl bits...
Comment 6 Michael Hampton 2007-02-01 17:28:05 EST
I'd love to, but in between filing this bug and now, I'd sold the computer. :(
Comment 7 Jarod Wilson 2007-02-02 09:29:40 EST
D'oh. In that case, I'll just close the bug out, hoping it was fixed upstream,
and if someone else runs into it, they can open a new bug...

Note You need to log in before you can comment on or make changes to this bug.