Bug 221690 - hald-addon-storage is insane
hald-addon-storage is insane
Status: CLOSED DUPLICATE of bug 221691
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-06 00:54 EST by Parag Warudkar
Modified: 2013-03-05 22:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-06 01:00:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Warudkar 2007-01-06 00:54:49 EST
Description of problem:
Every few nano seconds, hald-addon-storage wakes up, opens my CDROM and causes
in excess of 20% CPU. 

top - 00:44:24 up  8:36,  1 user,  load average: 0.41, 0.30, 0.27

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
 2430 root      16   0  1924  660  580 S   20  0.0  42:55.74 hald-addon-stor

Strace says it is repeatedly opening /dev/hdc - CDROM. Why in god's name does it
have to poll a CDROM so fast and why would it need 20% of CPU for that?


Version-Release number of selected component (if applicable):
hal-0.5.8.1-6.fc6

How reproducible:
Always

Steps to Reproduce:
1. Just run a FC6 system with CDROM drive and watch top output
2.
3.
  
Actual results:
hald-addon-storage sucks CPU like crazy

Expected results:
Should not wake up so often and should not cause this much CPU utilization.


Additional info:
It sucks when you find out your laptop's fans are blowing to keep
hald-addon-storage running and polling the non existend CD in the CDROM drive
and causing increased power consumption.
Comment 1 Parag Warudkar 2007-01-06 01:00:55 EST
Sorry my trackpad horizontal scrolling made me hit submit twice.

*** This bug has been marked as a duplicate of 221691 ***

Note You need to log in before you can comment on or make changes to this bug.