Bug 221693 - ttyS0 hangs during initial data transfer
ttyS0 hangs during initial data transfer
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
Blocks: 427887
  Show dependency treegraph
Reported: 2007-01-06 02:03 EST by Greg Guldenschuh
Modified: 2008-02-07 23:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-07 23:25:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Greg Guldenschuh 2007-01-06 02:03:18 EST
Description of problem:  This problem is in both FC5 and FC6 x86_64 NON ZEN
VERSION.  Running Hylafax on ttyS0, as soon as Hylafax answers the phone and
data transfer begins from the remote fax, the port appears to hang and nothing
will free it up.

Version-Release number of selected component (if applicable): FC5 and FC6 x86_64

How reproducible: Happens every time

Steps to Reproduce:
1.install either FC5 or FC6 x86_64 non Zen
2.install Hylafax and fax modem on ttyS0
3.send fax to Hylafax
Actual results: port appears to hang and remote fax gets line error.  

Expected results:

Additional info:  Dropping back to FC5 i386 completely eliminates the problem. 
Due to time constraints, I did not try FC6 i386.  The Zen version on FC6 x86_64
would not even recognize the serial port, but I believe that issue is addressed
in another report.  I would recommend checking FC6 x86_64 Zen to insure the
problem is not there once we get past the Zen taking over ttyS0 issue.
Comment 1 Jon Stanley 2008-01-07 20:48:16 EST
(This is a mass-update to all current FC6 kernel bugs in NEW state)


I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.


I am CC'ing myself to this bug, however this version of Fedora is no longer

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 2 Jon Stanley 2008-02-07 23:25:53 EST
Per the previous comment in this bug, I am closing it as INSUFFICIENT_DATA,
since no information has been lodged for over 30 days.

Please re-open this bug or file a new one if you can provide the requested data,
and thanks for filing the original report!

Note You need to log in before you can comment on or make changes to this bug.