Bug 221716 - Crash when selecting text in writer
Crash when selecting text in writer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 221719 221723 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-01-06 11:52 EST by Nicolas Mailhot
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.1.0-6.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-09 08:38:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2007-01-06 11:52:46 EST
Description of problem:

Crash when selecting text in writer with the mouse (fresh OO.o, just has the
time  to type a few words in the doc before selecting)

Version-Release number of selected component (if applicable):

openoffice.org-core-2.1.0-6.10

How reproducible:

always

Steps to Reproduce:
1. type a few words
2. highlight them with the mouse
3. boom
 
Additional info:

(I)    x.org loaded video driver of...
(II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-52-x86_64
(V)    kernel is: Linux 2.6.19-1.2904.fc7 #0 SMP Mon Jan 1 23:52:38 EST 2007
x86_64 x86_64 x86_64
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.1.0-6.10-x86_64
(VII)  depth of root window:    24 planes
(VIII) accessibility is: true
(VIV)  fedora release is: Fedora Core release 6 (Rawhide)
...start free space details ...
...end free space details ...
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0xaf3b06c8: /usr/lib64/openoffice.org2.1/program/libuno_sal.so.3 + 0x366c8
0xaf3b114b: /usr/lib64/openoffice.org2.1/program/libuno_sal.so.3 + 0x3714b
0xc0c30140: /lib64/libc.so.6 + 0x30140
0xaef020a2: /usr/lib64/openoffice.org2.1/program/libuno_cppuhelpergcc3.so.3 +
0x370a2
0xaef03a44: /usr/lib64/openoffice.org2.1/program/libuno_cppuhelpergcc3.so.3 +
0x38a44 (cppu::WeakImplHelper_query(com::sun::star::uno::Type const&,
cppu::class_data*, void*, cppu::OWeakObject*) + 0x144)
0xada74065: /usr/lib64/openoffice.org2.1/program/libsvt680lx.so + 0x183065
0xb1c26730: /usr/lib64/openoffice.org2.1/program/libfwk680lx.so + 0x6c730
0xada6be93: /usr/lib64/openoffice.org2.1/program/libsvt680lx.so + 0x17ae93
(TransferableHelper::CopyToSelection(Window*) const + 0x273)
0xab5bc52b: /usr/lib64/openoffice.org2.1/program/libsw680lx.so + 0x8b052b
0xab6f105e: /usr/lib64/openoffice.org2.1/program/libsw680lx.so + 0x9e505e
0xab5c9fe0: /usr/lib64/openoffice.org2.1/program/libsw680lx.so + 0x8bdfe0
0xad2b6bd5: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0x2a2bd5
0xad2b70bf: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0x2a30bf
0xb800d3c4: /usr/lib64/openoffice.org2.1/program/libvclplug_gtk680lx.so + 0x3d3c4
0xb3d603bd: /usr/lib64/libgtk-x11-2.0.so.0 + 0x1323bd
0x9d40af29: /lib64/libgobject-2.0.so.0 + 0xaf29 (g_closure_invoke + 0x109)
0x9d41a788: /lib64/libgobject-2.0.so.0 + 0x1a788
0x9d41b99d: /lib64/libgobject-2.0.so.0 + 0x1b99d (g_signal_emit_valist + 0x60d)
0x9d41bda3: /lib64/libgobject-2.0.so.0 + 0x1bda3 (g_signal_emit + 0x83)
0xb3e5e2ce: /usr/lib64/libgtk-x11-2.0.so.0 + 0x2302ce
0xb3d599cd: /usr/lib64/libgtk-x11-2.0.so.0 + 0x12b9cd (gtk_propagate_event + 0xfd)
0xb3d5a9e1: /usr/lib64/libgtk-x11-2.0.so.0 + 0x12c9e1 (gtk_main_do_event + 0x321)
0xb41f77ec: /usr/lib64/libgdk-x11-2.0.so.0 + 0x467ec
0x9d02d014: /lib64/libglib-2.0.so.0 + 0x2d014 (g_main_context_dispatch + 0x1b4)
0x9d02fe4d: /lib64/libglib-2.0.so.0 + 0x2fe4d
0x9d03037e: /lib64/libglib-2.0.so.0 + 0x3037e (g_main_context_iteration + 0x6e)
0xb7fe7ef5: /usr/lib64/openoffice.org2.1/program/libvclplug_gtk680lx.so + 0x17ef5
0xad0e1451: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0xcd451
(Application::Yield(bool) + 0x51)
0xad0e14ea: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0xcd4ea
(Application::Execute() + 0x2a)
0xaaad9685: /usr/lib64/openoffice.org2.1/program/libsoffice.so + 0x2c685
(desktop::Desktop::Main() + 0x15a5)
0xad0e6b29: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0xd2b29
0xad0e6c15: /usr/lib64/openoffice.org2.1/program/libvcl680lx.so + 0xd2c15
(SVMain() + 0x25)
0xaaacbef6: /usr/lib64/openoffice.org2.1/program/libsoffice.so + 0x1eef6
(sal_main + 0x46)
0xc0c1d924: /lib64/libc.so.6 + 0x1d924 (__libc_start_main + 0xf4)
0x400619: /usr/lib64/openoffice.org2.1/program/swriter.bin + 0x619
...end stackreport details ...
...start sample ldd details ...
	libuno_sal.so.3 => /usr/lib64/openoffice.org2.1/program/libuno_sal.so.3
(0x00002aaaaaccd000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib64/openoffice.org2.1/program/libuno_salhelpergcc3.so.3 (0x00002aaaab0c2000)
	libstore.so.3 => /usr/lib64/openoffice.org2.1/program/libstore.so.3
(0x00002aaaab2c6000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaab4f1000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aaaab6f5000)
	libstlport_gcc.so => /usr/lib64/openoffice.org2.1/program/libstlport_gcc.so
(0x00002aaaab90f000)
	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002aaaabbeb000)
	libm.so.6 => /lib64/libm.so.6 (0x00002aaaabeeb000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002aaaac16e000)
	libc.so.6 => /lib64/libc.so.6 (0x00002aaaac37c000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002aaaac6c8000)
	/lib64/ld-linux-x86-64.so.2 (0x00000000b9abd000)
...end sample ldd details ...
Comment 1 Caolan McNamara 2007-01-06 13:36:53 EST
*** Bug 221719 has been marked as a duplicate of this bug. ***
Comment 2 Caolan McNamara 2007-01-07 08:37:48 EST
*** Bug 221723 has been marked as a duplicate of this bug. ***
Comment 3 Caolan McNamara 2007-01-09 08:38:23 EST
All ok again in 2.1.0-6.11, agreed ?
Comment 4 Paul F. Johnson 2007-01-09 17:46:00 EST
C, you are brilliant. If we ever meet, remind me to buy you a couple of drinks
of your tipple!
Comment 5 Nicolas Mailhot 2007-01-09 17:56:43 EST
(In reply to comment #3)
> All ok again in 2.1.0-6.11, agreed ?

Agreed, thanks a lot!


Note You need to log in before you can comment on or make changes to this bug.