Bug 221733 - beryl in kcontrol ?
Summary: beryl in kcontrol ?
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: aquamarine   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-07 00:43 UTC by Chitlesh GOORAH
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 16:31:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (152.20 KB, image/png)
2007-01-07 00:43 UTC, Chitlesh GOORAH
no flags Details

Description Chitlesh GOORAH 2007-01-07 00:43:35 UTC
Description of problem:
there is a beryl item on kcontrol.
When I click on it, nothing happens.

see attached screenshot

chitlesh(SPECS)[0]$rpm -qa | grep beryl
beryl-plugins-0.1.4-2.fc6
beryl-gnome-0.1.4-2.fc6
beryl-0.1.4-2.fc6
beryl-settings-0.1.4-1.fc6
beryl-dbus-0.1.4-2.fc6
beryl-manager-0.1.4-1.fc6
beryl-kde-0.1.4-2.fc6
beryl-core-0.1.4-2.fc6

Comment 1 Chitlesh GOORAH 2007-01-07 00:43:35 UTC
Created attachment 144991 [details]
screenshot

Comment 2 Jarod Wilson 2007-01-08 22:32:52 UTC
I'm going to assume this is actually due to some of the additional bits in the
aquamarine package:

$ rpm -ql aquamarine
/usr/bin/aquamarine
/usr/lib64/beryl/backends/libkconfig.so
/usr/lib64/kde3/kcm_beryl.so
/usr/share/applications/kde/beryl.desktop
/usr/share/config.kcfg/aquamarine.kcfg
[...]

As for why its coming up blank, I dunno yet...

Comment 3 Chitlesh GOORAH 2007-01-08 23:04:16 UTC
Well I suspect it's a problem in FE guidelines.
Normally FE guideline says to remove that .la files from the package.
however it may seem that plugins for kcontrol require .la files if not they
don't work properly.

example: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=221015#c7

For this package :
It seems be the same problem:

chitlesh(~)[0]$cat /usr/share/applications/kde/beryl.desktop
[Desktop Entry]
Encoding=UTF-8
Exec=kcmshell beryl
Icon=beryl
Type=Application

X-KDE-Library=beryl
X-KDE-FactoryName=beryl
X-KDE-ParentApp=kcontrol

Name=Beryl

Categories=Qt;KDE;X-KDE-settings-looknfeel;

chitlesh(~)[0]$kcmshell beryl

I have: http://www.flickr.com/photo_zoom.gne?id=350939451&size=o

I'll compile the package again with the .la file and ill report back.

Comment 4 Chitlesh GOORAH 2007-01-08 23:26:52 UTC
Well, I was right, that was indeed the culprit.

I've commented the line:
#find $RPM_BUILD_ROOT -type f -name "*.a" -o -name "*.la" | xargs rm -f
from your spec file 0.1.4-2

I had 2 surplus files:
/usr/lib/beryl/backends/libkconfig.la
/usr/lib/kde3/kcm_beryl.la

Now I have a nice working beryl item on my kcontrol.
http://www.flickr.com/photo_zoom.gne?id=350963019&size=o

See whether you can get an icon before that beryl item on the kcontrol ;) that
would be perfect.

Comment 5 Jarod Wilson 2007-01-11 16:31:33 UTC
Poked around a bit, not immediately obvious to me how one adds an icon. For the
moment, just respinning with the .la files included so the kcontrol bit works.


Note You need to log in before you can comment on or make changes to this bug.