Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 221734 - Unable to Upgrade Pydev Because "org.junit" is Missing
Unable to Upgrade Pydev Because "org.junit" is Missing
Product: Fedora
Classification: Fedora
Component: eclipse-pydev (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
Depends On:
  Show dependency treegraph
Reported: 2007-01-06 20:21 EST by Chris Spencer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-08 13:55:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Spencer 2007-01-06 20:21:58 EST
Description of problem:
If you try to upgrade Pydev using Eclipse's plugin update feature, Eclipse will
refuse to install Pydev 1.2.5, giving the error message 'PyDev for Eclipse
(1.2.5) requires plug-in "org.junit".' This is an odd message because JUnit is
included with Eclipse 3.1.

Version-Release number of selected component (if applicable):
Eclipse 3.1

Steps to Reproduce:
1. Go to Help/Software Update/Find and Install...
2. Select "Search for new features to install", then click "Next"
3. Create a remote site for Pydev updates at http://pydev.sf.net/updates/
4. Check Pydev within the "Sites to include in search" box, then click "Finish".
5. Check Pydev within the "Select the features to install" box.
6. Notice the error message at the top of the dialog.
Comment 1 Ben Konrath 2007-01-08 13:55:44 EST
When I run those steps, I get:

"PyDev for Eclipse (1.2.5) requires plug-in "org.eclipse.ui.ide (3.2.0)", or
later version."

And according to the project page Pydev does in fact require Eclipse SDK 3.2.
Pydev also requires a JVM that is compatible with Java 5. Since both of these
aren't in FC5 I'm going to close this bug.

FC6 has Eclispe SDK 3.2 but no Java 5. If you go that route, you'll have to use
a proprietary VM that supports Java 5. Thanks. 

Note You need to log in before you can comment on or make changes to this bug.