Bug 221762 - TinyFugue unusable due to display errors in visual mode, also crashes
TinyFugue unusable due to display errors in visual mode, also crashes
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: tinyfugue (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Callum Lerwick
Fedora Extras Quality Assurance
http://lists.tcp.com/pipermail/tinyfu...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-07 12:06 EST by Thomas Whaples
Modified: 2016-02-03 12:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 00:31:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot, visual mode (broken) (658 bytes, text/plain)
2007-01-07 12:12 EST, Thomas Whaples
no flags Details
Screenshot, visual mode (working) (638 bytes, text/plain)
2007-01-07 12:14 EST, Thomas Whaples
no flags Details

  None (edit)
Description Thomas Whaples 2007-01-07 12:06:32 EST
Description of problem:
The 'visual' mode of TinyFugue (which features a status bar and separate input
and output areas) is unusable. The display of the status bar is distorted.
Keyboard input does not begin at the left of the screen, and may overflow from
the input area to cover portions of the status bar and output area.

Additionally, TinyFugue may sometimes crash for reasons which are not clear when
it is in non-visual mode while the Backspace key is being used.

Version-Release number of selected component (if applicable):
tinyfugue-5.0-0.5.b7.fc6.x86_64.rpm

How reproducible:
Visual mode errors always reproducible. Crashes when not in visual mode and when
the backspace key is being used only occur erratically.

Steps to Reproduce:
1. Launch TinyFugue with visual mode on (default)
  
Actual results:
TinyFugue status bar is not centered on the screen, but begins two or three
characters to the right of the screen's left edge. Input begins several
characters to the left of the screen's right edge.

Expected results:
TinyFugue status bar is centered on screen, stretching from the screen's left
edge to the screen's right edge.

Additional info:
The following crash message was displayed after TinyFugue crashed in non-visual
mode while attempting to use the Backspace key. This message has been produced
during the above circumstances on at least two occasions. I have reported this
message to hawkeye at tcp.com and the TinyFugue mailing list, tf@tcp.com.


-- message follows --


Please report the following message verbatim to hawkeye at tcp.com.
Also describe what you were doing in tf when this
occured, and whether you can repeat it.

> TinyFugue version 5.0 beta 7
> Linux #1 SMP Tue Jul 11 22:53:56 EDT 2006 2.6.17-1.2157_FC5
> +256colors +core +float +ftime +history +IPv6 +locale +MCCPv1 +MCCPv2 +process
-SOCKS +ssl +subsecond +TZ
> virtscreen=1, visual=0, expnonvis=0, emulation=3, lp=0, sub=0
> TERM="screen"
> cmd="(NULL)"
> Internal error:  output.c, line 2501
> dSnadd: n==-1
Comment 1 Thomas Whaples 2007-01-07 12:12:07 EST
Created attachment 145006 [details]
Screenshot, visual mode (broken)

This is a text-mode screenshot of the way that the buggy version of TinyFugue
appears when it starts up.
Comment 2 Thomas Whaples 2007-01-07 12:14:08 EST
Created attachment 145007 [details]
Screenshot, visual mode (working)

This is a (text-mode) screenshot of a different version of TinyFugue starting
up in visual mode, with visual mode working properly. Note the status bar
separating the input area (three blank lines at the bottom) from the output
area (the rest of the screen).
Comment 3 Callum Lerwick 2007-01-10 00:31:52 EST
So I'm not the only one using tf! Yeah, this broke a while back and... hmmm, why
isn't tf linked against ncurses? How long has it been like that...

It must be falling back on hardcoded (and broken) VT100 support because
ncurses-devel isn't being pulled into the buildroot. I just rebuilt it locally
with BR: ncurses-devel and that seems to fix it.

Apparently ncurses-devel got split out from the main ncurses package in FC6 for
reasons of multilib, and I didn't notice because it didn't break the build.

Pushing fixed builds now, they should hit the mirrors within a day.
Comment 4 mes2012 2016-02-03 12:29:12 EST
Hey, this is still happening unfortunately - I realize that this bug is 8 years old, but having the same issue with unusable display in visual mode.
Comment 5 mes2012 2016-02-03 12:33:36 EST
TF version:
% TinyFugue version 5.0 beta 8.
% Copyright (C) 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2002, 2003, 2004,
2005, 2006-2007 Ken Keys (kenkeys@users.sourceforge.net).
% Built for Linux #1 SMP Sun Jan 24 04:20:14 EST 2016 4.3.4-grsec

OS version:
Linux 4.3.4-grsec #1 SMP Sun Jan 24 04:20:14 EST 2016 x86_64 GNU/Linux

Note You need to log in before you can comment on or make changes to this bug.