Bug 221768 - prism54 drivers stops working with NetworkManager and dhcp
prism54 drivers stops working with NetworkManager and dhcp
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-07 15:34 EST by Jon Nettleton
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-01 13:53:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix WEP and unencrypted modes (939 bytes, patch)
2007-02-05 10:06 EST, Dan Williams
no flags Details | Diff
Don't mistakenly turn on DOT1XENABLE (fixes non-WPA useage with wpa_supplicant) (969 bytes, patch)
2007-02-15 07:48 EST, Dan Williams
no flags Details | Diff

  None (edit)
Description Jon Nettleton 2007-01-07 15:34:32 EST
Testing kernel-2.6.19-1.2888.fc6 resulted in my prism54 wireless card no longer
working with dhcp and NetworkManager.  A manual ifup of the interface does
establish a wireless connection and obtains a dhcp address from the server.  The
netdev test kernel has this same problem, but the standard Core 6 kernels work fine.
Comment 1 John W. Linville 2007-01-10 10:06:35 EST
So, after the manual ifup does traffic flow over the interface?  Is the 
problem just that NetworkManager isn't activating the interface?
Comment 2 Jon Nettleton 2007-01-10 10:20:27 EST
That is correct.  TCP and UDP traffic and broadcast pings all work properly.

I did some more testing and realized that the bootps packets to the broadcast
address weren't going anywhere.  I could see them created on the wireless
interface, but they could not be seen by any of the computers on the network.

So possibly a problem with wpa_supplicant?  Or broadcast packet creation?
Comment 3 John W. Linville 2007-01-10 11:30:03 EST
The prism54 sources appear to be the same between 2894.fc6 and 2869.fc6.  Can 
you be more specific about which "standard Core 6 kernels" you are using that 
work?

FWIW, I don't see any recent upstream prism54 changes that are likely to have 
caused this issue anyway.  Hmmm...
Comment 4 Luis R. Rodriguez 2007-01-10 11:59:45 EST
The fact that wpa_supplicant is mentioned makes me worry about this bug report
as prism54 never really completed wpa support through wpa_supplicant. Also just
a note: prism FullMAC cards tend to be really flaky and as such most issues I
have seen with them tend to be hardware going awry.
Comment 5 Luis R. Rodriguez 2007-01-10 12:01:02 EST
Adding me to the CC list
Comment 6 Jon Nettleton 2007-01-10 12:17:12 EST
I do understand that the prism FULLMAC cards are not perfect.  I have been
through all the trials and tribulations of using NetworkManager with this card
from the beginning.  Most of Fedora Core 5 and 6 have been very stable and I
have had very few issues.  Sometimes I get the Management Queue issues and such,
but nothing that doesn't usually get fixed up by attempting a reconnect to the
AP so the hardware gets reset.  

I have been reading the netdev list to get some background on the WPA patch that
was added.  This patch also appears to be in 2.6.19 because I am seeing WPA
support listed in NM.  Is it possible this could be the culprit?
Comment 7 Dan Williams 2007-01-10 13:12:41 EST
prism54 FullMAC is supposed to support some manner of WPA (at least TKIP)
through private hostap-based ioctls.  NetworkManager does not use those ioctls
at all, and requires WEXT compatibility.  I did upstream a patch that provides
some support for WPA via the standard WEXT calls, but I didn't think that WEXT
WPA patch was in 2.6.18 kernels, and was targetted for 2.6.19.

There is an _additional_ patch on netdev (from "chunky"??) that fixes a few
things, but is still in very rough shape and not suitable for wireless-dev let
alone Linus.
Comment 8 John W. Linville 2007-01-10 13:25:41 EST
FWIW, Dan's WPA patch is the first prism54 patch after 2.6.18.  Depending on 
which FC6 kernel was the one that was working, Dan's patch _could_ be the 
culprit.  I'll spin a FC6 test kernel that backs-out Dan's patch.

What is the FC6 kernel version that was working for you?
Comment 9 Jon Nettleton 2007-01-10 14:16:41 EST
2.6.18-1.2869.fc6 is working

The 2.6.19 kernel Dave wanted us to try out does not work.

2.6.19-1.2888.fc6

None of the recent netdev rpm kernels work either.
Comment 10 John W. Linville 2007-01-11 13:57:12 EST
I think this is unlikely to help, but...

Test kernels w/ dcbw's prism54 wpa patch removed are available here:

   http://people.redhat.com/linville/kernels/fc6/

Please give them a try and post the results here...thanks!
Comment 11 Jon Nettleton 2007-01-11 14:13:56 EST
That patch was the problem.  This kernel works fine for me.  

I am happy to test any other patches related to this chipset.
Comment 12 John W. Linville 2007-01-11 14:19:16 EST
I'll scratch my head for a bit while I wait to see if dcbw has anything to 
offer... :-)
Comment 13 Dan Williams 2007-01-11 15:24:50 EST
I don't really have anything; my prism54 fullmac card broke or something, since
it doesn't work with the patch, and doesn't work without the patch; it never
associates to anything in any configuration...  You could back out the commit
for the time being from wireless-dev or something.
Comment 14 Jon Nettleton 2007-01-12 09:48:16 EST
I do have an extra prism54 mini-pci card that I could loan you if it would help.
 I assume you would need a pcmcia card though.
Comment 15 Dan Williams 2007-01-12 10:42:30 EST
Not necessarily; I've got a laptop here that I've kept around that has quite
easy MiniPCI card access (Dell Latitude 610).

Linville; would you want that card, or should I take a look?  I don't think it
would be that hard to debug, but I might not be able to get the card back for a
few months.
Comment 16 John W. Linville 2007-01-12 11:03:55 EST
Dan I think you are as good a person to take it as any.  You are probably the 
most familiar with the patch anyway.
Comment 17 Jon Nettleton 2007-01-15 12:11:42 EST
Sorry, for the delay.  A couple-few months is fine.  It has been collecting dust
here for a year or so now.  Mail me offline where you want it sent to.
Comment 18 Nils Philippsen 2007-01-28 09:29:40 EST
Just a quick "me too", let me know if therte is something I can test/help with.
Comment 19 Dan Williams 2007-02-03 18:28:35 EST
What configurations are people using?  unencryped?  WEP?  WPA-anything?
Comment 20 Jon Nettleton 2007-02-04 00:30:05 EST
for me, WEP and Unencrypted failed.  I have not tried WPA 
Comment 21 Nils Philippsen 2007-02-05 06:28:43 EST
I've only tried WEP so far as WPA has been a no-go for me with my prism54 card
so far. Shout if I should give WPA a try.
Comment 22 Dan Williams 2007-02-05 08:05:22 EST
I debugged WEP last night; I know what's wrong there.  WPA is a no-go, but it
doesn't even appear to work with the 'hostap' wpa_supplicant driver, for which
handler code has been around for ages.  Has prism54 _ever_ worked for WPA-TKIP
after, say, 2.6.13 or so?
Comment 23 Nils Philippsen 2007-02-05 08:31:55 EST
I honestly don't know... The only thing I have heard (and may be completely
bogus) about prism54 and WPA is that the driver doesn't offer some kind of
standard API for WPA but its own thing and that doesn't work with NM. Whether or
not that own thing works/-ed or not I can't say.
Comment 24 Dan Williams 2007-02-05 10:06:07 EST
Created attachment 147357 [details]
Fix WEP and unencrypted modes
Comment 25 Dan Williams 2007-02-05 10:07:37 EST
John; can you spin a test kernel with this patch?  If it works for others, I'll
take care of the submission to the wireless list.
Comment 26 Luis R. Rodriguez 2007-02-05 11:27:39 EST
FWIW this card can support only WPA TKIP through hardware. That's it, also I
never was able to complete WPA support for the driver. Recently there was a
patch which added its support but unfortunately I never got around to test it. I
believe that patch got integrated and then got reverted during the end of this
bug report.
Comment 27 John W. Linville 2007-02-05 18:05:10 EST
Dan, et al. -- test kernels are available here:

   http://people.redhat.com/linville/kernels/fc6/

Please give those a try and post the results here...thanks!
Comment 28 Jon Nettleton 2007-02-07 18:44:34 EST
The kernel with these patches works for me.  Thanks for debugging this problem.
Comment 29 Dan Williams 2007-02-13 14:21:56 EST
The patch was erroneous, but had the intended result anyway.  I've posted the
correct patch to linux-wireless@vger.  John, I assume you'll take it from here?
Comment 30 Philippe Troin 2007-02-15 04:37:12 EST
Dan,

Would you mind posting the patch here?
I can't find an archive of linux-wireless :-/
I'm seeing the same problem on fc5 with 2.6.19-1.2288.fc5.
Comment 31 Dan Williams 2007-02-15 07:48:19 EST
Created attachment 148106 [details]
Don't mistakenly turn on DOT1XENABLE (fixes non-WPA useage with wpa_supplicant)

Corrected patch as posted to linux-wireless and stable@vger
Comment 32 John W. Linville 2007-03-01 13:53:24 EST
This patch is merged upstream, and should be available in Fedora when Fedora 
moves to 2.6.21-based kernels.

Note You need to log in before you can comment on or make changes to this bug.