Bug 221780 - memory leak in virt-manager
memory leak in virt-manager
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-07 17:41 EST by Charles R. Anderson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: pygobject2-2.12.3-2.fc6 and pygobject2-2.12.3-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 15:03:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2007-01-07 17:41:33 EST
Description of problem:
virt-manager was found to be using over a gigabyte of resident RAM after running
for a week.

Version-Release number of selected component (if applicable):
virt-manager-0.2.6-3.fc6
libvirt-0.1.10-1.fc6

How reproducible:
didn't try

Steps to Reproduce:
1. run FC6 guest in FC6 host
2. run virt-manager w/graphical and serial consoles open
3. keep virt-manager open with graphs displaying activity
  
Actual results:
1.3G RSS in python process after a week

Expected results:
no memory leak

Additional info:
Comment 1 Hugh Brock 2007-06-18 15:03:42 EDT
This turns out to be a pygtk bug. It is fixed in pygobject2-2.12.3-2.fc6 and
pygobject2-2.12.3-3.fc7.

Note You need to log in before you can comment on or make changes to this bug.