Bug 221789 - video display is distorted
video display is distorted
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-nv (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Dave Airlie
desktop-bugs@redhat.com
:
Depends On:
Blocks: 222082 222737 RHEL5u2_relnotes RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2007-01-07 20:14 EST by John Poelstra
Modified: 2008-11-18 19:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
(amd64) Some machines that use NVIDIA graphics cards may display corrupted graphics or fonts when using the graphical installer or during a graphical login. To work around this, switch to a virtual console and back to the original X host.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 10:44:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
login (206.25 KB, image/jpeg)
2007-01-07 20:14 EST, John Poelstra
no flags Details
installer (183.29 KB, image/jpeg)
2007-01-07 20:15 EST, John Poelstra
no flags Details
notification with unreadable fonts (192.18 KB, image/jpeg)
2007-01-07 20:16 EST, John Poelstra
no flags Details
web browser font problem (268.95 KB, image/jpeg)
2007-01-07 20:17 EST, John Poelstra
no flags Details
xorg.conf--as created automatically by installer (564 bytes, text/plain)
2007-01-07 20:24 EST, John Poelstra
no flags Details

  None (edit)
Description John Poelstra 2007-01-07 20:14:00 EST
Description of problem:

After booting the X display is garbled and unclear while switching to virutal
console screen is very clear.  Garbled screen clears up after switching to a
virutal console and switching back to X (F7).  The machine is a Dell Precision
470 and has an Nvidia NV44 [Quadro NVS 285] (rev a1) video card.  I am only
running stock RHEL5 packages.  It appears that RHEL5 is automatically installing
and using the "nv" driver.

I have been seeing this problem for the past 3 few weeks running while contining
to update to the latest nightlies for RHEL5.  Today I reinstalled my machine
with RHEL5-Client-20070105.0/4.92/x86_64/os (latest snapshot) to make sure I had
a clean install.

Before the reinstall I would see this problem once every 3 or 4 boots... I power
the machine off each night and power on each morning.

Version-Release number of selected component (if applicable):
 rpm -qa | grep ^x
xorg-x11-font-utils-7.1-2
xorg-x11-server-utils-7.1-4.fc6
xmlsec1-1.2.9-8.1
xsri-2.1.0-10.fc6
xml-common-0.6.3-18
xml-commons-resolver-1.1-1jpp.12
xorg-x11-fonts-base-7.1-2.1.el5
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2.1.el5
xorg-x11-drv-void-1.1.0-3.1
xorg-x11-drv-hyperpen-1.1.0-2
xorg-x11-drv-digitaledge-1.1.0-1.1
xorg-x11-drv-cirrus-1.1.0-2.fc6
xorg-x11-drv-vmware-10.13.0-2.1
xorg-x11-drv-palmax-1.1.0-1.1
xalan-j2-2.7.0-6jpp.1
xorg-x11-fonts-Type1-7.1-2.1.el5
xorg-x11-drv-mouse-1.1.1-1.1
xorg-x11-drv-dynapro-1.1.0-2
xorg-x11-drv-s3-0.4.1-2.1
xorg-x11-drv-vga-4.1.0-2.1
xorg-x11-drv-nv-1.2.0-4.fc6
xorg-x11-drv-magictouch-1.0.0.5-2.1
xorg-x11-drv-fbdev-0.3.0-2
xkeyboard-config-0.8-7.fc6
xml-commons-1.3.02-0.b2.7jpp.10
xorg-x11-utils-7.1-2.fc6
xerces-j2-2.7.1-7jpp.2
xorg-x11-xfs-1.0.2-3.1
xorg-x11-fonts-truetype-7.1-2.1.el5
xorg-x11-drv-keyboard-1.1.0-2.1
xsane-gimp-0.991-4.el5
xorg-x11-server-Xorg-1.1.1-48.12.el5
xorg-x11-drv-dmc-1.1.0-2
xorg-x11-drv-ur98-1.1.0-1.1
xorg-x11-drv-trident-1.2.1-3.fc6
xorg-x11-drv-via-0.2.1-8
xorg-x11-drv-microtouch-1.1.0-1.1
xorg-x11-drv-joystick-1.1.0-1.1
xorg-x11-drv-s3virge-1.9.1-2.1
xorg-x11-drv-savage-2.1.1-5.fc6
xorg-x11-drv-jamstudio-1.1.0-1.1
xorg-x11-drv-sisusb-0.8.1-4.1
xorg-x11-drv-elographics-1.1.0-1.1
xorg-x11-drivers-7.1-4.1.el5
xorg-x11-xkb-utils-1.0.2-2.1
xmlsec1-1.2.9-8.1
xorg-x11-xinit-1.0.2-13.el5
xterm-215-4.el5
xml-commons-apis-1.3.02-0.b2.7jpp.10
xorg-x11-server-Xvfb-1.1.1-48.12.el5
xorg-x11-fonts-misc-7.1-2.1.el5
xorg-x11-fonts-75dpi-7.1-2.1.el5
xsane-0.991-4.el5
xorg-x11-drv-vmmouse-12.4.0-2.1
xorg-x11-drv-tek4957-1.1.0-1.1
xorg-x11-drv-ast-0.81.0-3
xorg-x11-drv-penmount-1.1.0-2.1
xorg-x11-drv-ati-6.6.3-3.2.el5
xorg-x11-drv-aiptek-1.0.1-2
xorg-x11-drv-i810-1.6.5-9.2.el5
xorg-x11-drv-sis-0.9.1-7
xorg-x11-drv-voodoo-1.1.0-3.1
xorg-x11-drv-spaceorb-1.1.0-1.1
xorg-x11-drv-siliconmotion-1.4.1-2.1
xorg-x11-filesystem-7.1-2.fc6
xorg-x11-xauth-1.0.1-2.1
xorg-x11-server-Xnest-1.1.1-48.12.el5
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2.1.el5
xorg-x11-drv-evdev-1.0.0.5-2.el5
xorg-x11-drv-mga-1.4.2-5.el5
xorg-x11-drv-citron-2.2.0-1.1
xorg-x11-drv-summa-1.1.0-1.1
xorg-x11-drv-tdfx-1.2.1-3.1
xorg-x11-drv-mutouch-1.1.0-2
xorg-x11-drv-acecad-1.1.0-2.1
xorg-x11-twm-1.0.1-3.1
xorg-x11-apps-7.1-4.el5
xorg-x11-drv-vesa-1.2.1-5.1.el5
xorg-x11-fonts-100dpi-7.1-2.1.el5
xorg-x11-drv-magellan-1.1.0-1.1
xorg-x11-drv-calcomp-1.1.0-1.1
xorg-x11-drv-elo2300-1.1.0-1.1
xorg-x11-drv-dummy-0.2.0-2.1
xorg-x11-drv-fpit-1.1.0-1.1

Steps to Reproduce:
1. Boot the machine
2.
3.
  
Actual results:
Sometimes the screen and fonts are garbled (see screenshots)

Expected results:
Screen is clear 100% of time time.

Additional info:lspci
00:00.0 Host bridge: Intel Corporation E7525 Memory Controller Hub (rev 09)
00:00.1 Class ff00: Intel Corporation E7525/E7520 Error Reporting Registers (rev 09)
00:02.0 PCI bridge: Intel Corporation E7525/E7520/E7320 PCI Express Port A (rev 09)
00:03.0 PCI bridge: Intel Corporation E7525/E7520/E7320 PCI Express Port A1 (rev 09)
00:04.0 PCI bridge: Intel Corporation E7525/E7520 PCI Express Port B (rev 09)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R)
AC'97 Audio Controller (rev 02)
01:00.0 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge A
01:00.2 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge B
03:0e.0 Ethernet controller: Intel Corporation 82545GM Gigabit Ethernet
Controller (rev 04)
05:00.0 VGA compatible controller: nVidia Corporation NV44 [Quadro NVS 285] (rev a1)
06:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 08)
06:0d.1 Input device controller: Creative Labs SB Live! Game Port (rev 08)
Comment 1 John Poelstra 2007-01-07 20:14:58 EST
Created attachment 145015 [details]
login
Comment 2 John Poelstra 2007-01-07 20:15:40 EST
Created attachment 145016 [details]
installer
Comment 3 John Poelstra 2007-01-07 20:16:31 EST
Created attachment 145017 [details]
notification with unreadable fonts
Comment 4 John Poelstra 2007-01-07 20:17:46 EST
Created attachment 145018 [details]
web browser font problem
Comment 5 John Poelstra 2007-01-07 20:20:15 EST
Admitedly the work around to switch to a virtual console and switch back to X is
fairly easily, but the appearance of the screen is a horrible first impression
to give our customers about the quality of our product.
Comment 6 John Poelstra 2007-01-07 20:24:49 EST
Created attachment 145020 [details]
xorg.conf--as created automatically by installer
Comment 7 Adam Jackson 2007-01-08 18:57:54 EST
Sounds like

https://bugzilla.novell.com/show_bug.cgi?id=220197

which is a trivially correct fix already present in rawhide.  Does it work if
you install the nv driver from rawhide?
Comment 8 John Poelstra 2007-01-09 00:45:15 EST
I read through the Novell bug and it is hard (for me) to see how it is the same
issue I reported.

Please provide a pointer to the exact package(s) that need to be installed from
rawhide.
Comment 9 Adam Jackson 2007-01-09 10:00:35 EST
https://bugzilla.novell.com/show_bug.cgi?id=220197#c25 - describes screen being
garbled and then fixed by VT switch.

http://porkchop.devel.redhat.com/brewroot/packages/xorg-x11-drv-nv/1.2.2.1/1.fc7/x86_64/xorg-x11-drv-nv-1.2.2.1-1.fc7.x86_64.rpm
 - is the nv driver currently in rawhide.
Comment 10 John Poelstra 2007-01-09 16:11:13 EST
installed xorg-x11-drv-nv-1.2.2.1-1.fc7.x86_64.rpm and am running it on my
primary desktop.  Haven't seen any issues so far.  I don't know an easy way to
trigger the original problem I was having to say for sure that this driver fixes
the problem.  I did do a few reboots and everything looks fine so far.  I'll
keep you posted if I see any other weirdness.
Comment 11 Adam Jackson 2007-01-09 16:28:15 EST
Devel ack.
Comment 12 John Poelstra 2007-01-11 11:25:18 EST
Just booted machine from cold state seeing the problem reported.  I watched the
entire boot process and the distortion firs appears at the gdm login screen. 
I'm still running the nv driver from comment#10
Comment 13 Adam Jackson 2007-01-11 16:54:06 EST
Move to 5.1.  We're not likely to get this done for 5.0, as the nv driver is
sufficiently obfuscated.  Should engage nvidia on this though, and would be a
z-stream candidate.
Comment 14 John Poelstra 2007-01-15 12:51:23 EST
I propose that at least a release note be considered for 5.0 for this issue.
Comment 15 Adam Jackson 2007-01-15 15:56:11 EST
(In reply to comment #14)
> I propose that at least a release note be considered for 5.0 for this issue.

Agreed, although it may be too late to get it translated...

Suggested text:

"When starting the graphical installer or graphical login, some NVIDIA cards may
display corrupted graphics.  The workaround is to switch virtual console and
back to graphics."
Comment 18 Adam Jackson 2007-06-04 15:43:31 EDT
John, have you seen this issue with the nv driver in F7?  I'm essentially going
to be backporting that driver anyway, would like to know if it's two birds with
one stone here.
Comment 19 John Poelstra 2007-06-04 15:48:22 EDT
saw it just yesterday... i'm running some mixture of F7T4 + rawhide (slightly
before GA).

What package versions would be helpful to know if I'm running?
Comment 20 Adam Jackson 2007-06-06 13:58:34 EDT
(In reply to comment #19)
> saw it just yesterday... i'm running some mixture of F7T4 + rawhide (slightly
> before GA).
> 
> What package versions would be helpful to know if I'm running?

xorg-x11-server-Xorg and xorg-x11-drv-nv.
Comment 21 John Poelstra 2007-06-06 18:01:09 EDT
# rpm -qi xorg-x11-server-Xorg
Name        : xorg-x11-server-Xorg         Relocations: (not relocatable)
Version     : 1.3.0.0                           Vendor: Koji
Release     : 5.fc7                         Build Date: Fri 11 May 2007 01:18:23
PM PDT
Install Date: Tue 15 May 2007 10:34:48 PM PDT      Build Host:
xenbuilder4.fedora.phx.redhat.com
Group       : User Interface/X              Source RPM:
xorg-x11-server-1.3.0.0-5.fc7.src.rpm
Size        : 7443859                          License: MIT/X11
Signature   : (none)
Packager    : Koji
URL         : http://www.x.org
Summary     : Xorg X server
Description :
X.org X11 is an open source implementation of the X Window System.  It
provides the basic low level functionality which full fledged
graphical user interfaces (GUIs) such as GNOME and KDE are designed
upon.
#
# rpm -qi xorg-x11-drv-nv
Name        : xorg-x11-drv-nv              Relocations: (not relocatable)
Version     : 2.0.2                             Vendor: Koji
Release     : 2.fc7                         Build Date: Thu 10 May 2007 07:06:20
AM PDT
Install Date: Mon 14 May 2007 10:23:41 PM PDT      Build Host:
xenbuilder2.fedora.redhat.com
Group       : User Interface/X Hardware Support   Source RPM:
xorg-x11-drv-nv-2.0.2-2.fc7.src.rpm
Size        : 173747                           License: MIT
Signature   : (none)
Packager    : Koji
URL         : http://www.x.org
Summary     : Xorg X11 nv video driver
Description :
X.Org X11 nv video driver.

Comment 22 Adam Jackson 2007-06-25 11:16:07 EDT
Have you tried xorg-x11-drv-nv 2.1.0 in F7 yet?  Has a fix for something that
sounds like a similar problem.
Comment 23 John Poelstra 2007-07-10 12:28:06 EDT
i just installed 2.1.1-1.fc8 from rawhide to my F7 box... will see how it goes.

If you want me to run a specific version, please send me a pointer to its location.

Thanks,
john
Comment 25 Adam Jackson 2007-07-26 14:59:36 EDT
(In reply to comment #24)
> Hi John, ajax,
> 
> a clone for this bug (BZ#222737) was put up months ago to include mention of
> this bug in the release notes as follows:
> 
> <quote>
> Some machines that use NVIDIA graphics cards may display corrupted graphics or 
> fonts when using the graphical installer or during a graphical login. To work 
> around this, switch to a virtual console and back to the original X host. 
> </quote>
> 
> as this bug is still not MODIFIED yet, should we add this same note to the
> RHEL5.1 release note? please advise. 

Yeah, probably a good idea.
Comment 26 Adam Jackson 2007-07-26 15:38:46 EDT
(In reply to comment #23)
> i just installed 2.1.1-1.fc8 from rawhide to my F7 box... will see how it goes.
> 
> If you want me to run a specific version, please send me a pointer to its
location.

Any news?
Comment 27 John Poelstra 2007-07-26 18:59:46 EDT
No adverse affects.  Seems to be running well.  I don't recall having to switch
to a virtual console to clear the screen since running this version.
Comment 28 Don Domingo 2007-07-26 22:08:53 EDT
as per John's report, not adding this to the RHEL5.1 release notes. seems to
have already been resolved. if anybody thinks this assessment is premature and
the relnote is still needed, please advise. thanks!

(In reply to comment #27)
> No adverse affects.  Seems to be running well.  I don't recall having to switch
> to a virtual console to clear the screen since running this version.

Comment 29 John Poelstra 2007-08-01 20:15:05 EDT
Sadly... I just encountered the problem again.  Had to switch to virtual console
3 times to clear the display from the login screen.  

Trying to reproduce this is difficult if not impossible because I do not know
what cause it to happen.
Comment 30 Don Domingo 2007-08-01 22:33:22 EDT
thanks for the heads-up, John. adding this known issue again to RHEL5.1 release
notes.
Comment 32 Adam Jackson 2007-08-08 16:25:00 EDT
Fixing component, xorg-x11 isn't included in RHEL5.
Comment 33 Adam Jackson 2007-08-16 15:01:29 EDT
I don't have a good lead for this, so I'm retargetting for 5.2.
Comment 36 Adam Jackson 2007-11-09 13:05:48 EST
No known solution yet.  Will miss 5.2 unless we figure it out.

I _think_ it's just a palette setup bug, but that should be the same between the
init and vt-switch paths.
Comment 38 Don Domingo 2008-01-17 18:33:04 EST
same release note added to "known issues" section of RHEl5.2 release notes.

please advise when resolved. thanks!
Comment 39 Dave Airlie 2008-01-18 01:02:59 EST
John have you got this machine and F8 or rawhide? I've just pushed a rawhide
xorg-x11-drv-nv-2.1.6-5.fc9 and I'm going to scratch build some F8 test packages,

f8 scratch packages are http://koji.fedoraproject.org/scratch/airlied/task_356197/

I got the idea for the fix from the nouveau guys.

I might just put the patch into RHEL5.2 as it won't break anything.
Comment 40 Dave Airlie 2008-01-18 16:55:00 EST
pushing out to 5.3 due to not having time before 5.2 freeze.
Comment 41 John Poelstra 2008-01-18 17:19:37 EST
Dave, I still have the hardware and am running F8.  I've installed from the koji
link above and will let you know if I see any problems.  It is intermittent so
hard to reproduce and could take a while to appear.
Comment 42 Don Domingo 2008-04-01 22:13:58 EDT
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don
Comment 43 Zack Cerza 2008-04-02 10:23:28 EDT
I do see the release note in the mockup.
Comment 44 John Poelstra 2008-04-22 17:37:32 EDT
FWIW.... still seeing the problem with latest rawhide packages (2008-APR)
Comment 47 Ryan Lerch 2008-08-07 21:35:01 EDT
Tracking this bug for the Red Hat Enterprise Linux 5.3 Release Notes. 

This Release Note is currently located in the Known Issues section.
Comment 48 Ryan Lerch 2008-08-07 21:35:01 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.
Comment 50 RHEL Product and Program Management 2008-09-11 10:44:45 EDT
Quality Engineering Management has reviewed and declined this request.  You may
appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.