Bug 22180 - Internal compiler error in print_operand_address
Summary: Internal compiler error in print_operand_address
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-12 20:32 UTC by Carl Thompson
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-12 22:24:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carl Thompson 2000-12-12 20:32:19 UTC
gcc/g++ fails with internal compiler error in
print_operand_address when compiling FLTK2 from cvs with
--enable-shared option (adds -fPIC).

Details:

g++ -I.. -DFL_LIBRARY -fPIC -DFL_SHARED -g  -Wall  -I/usr/X11R6/include -fno-exceptions -c fl_vertex.cxx -o fl_vertex.shared.o
fl_vertex.cxx: In function `void fl_push_matrix ()':
fl_vertex.cxx:41: Internal compiler error in print_operand_address, at
config/i386/i386.c:3404
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.

The source used can be grabbed from
http://carlthompson.net/fltk

Comment 1 Jakub Jelinek 2000-12-12 20:43:24 UTC
Can you please rerun g++ with the above options and -save-temps -v
options and post the resulting fl_vertex.ii file?

Comment 2 Carl Thompson 2000-12-12 20:49:10 UTC
Sorry, I have already uninstalled the compiler.


Comment 3 Bill Nottingham 2000-12-12 22:17:43 UTC
Unfortunately, then, we can't do much to help you.

Comment 4 Carl Thompson 2000-12-12 22:24:49 UTC
Well, you could ship compilers that work in your product!  Furthermore,  I _did_
point to where you can get the problematic source code so you can fix the
problem without me doing part of the work for you!  (I assume you are getting
paid by Red Hat to fix these problems whereas I am not.)


Comment 5 Bill Nottingham 2000-12-12 23:12:14 UTC
All we ask is that you follow the bug reporting procedure that the compiler
itself printed out; with the preprocessed source we can eliminate any
possible dependencies on other system variables.

In any case, I can't reproduce it with gcc-2.96-65, so I can only assume
it's fixed in the currently available rawhide package.


Note You need to log in before you can comment on or make changes to this bug.