Bug 221804 - kernel panic on boot from IDE hard drive
kernel panic on boot from IDE hard drive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-08 01:28 EST by Richard Hally
Modified: 2008-04-04 12:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 12:56:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hally 2007-01-08 01:28:04 EST
Description of problem: Kernel panic with any 2.6.19 rawhide kernel.
the error produced when booting kernel-2.6.19-1.2905.fc7
is:
"/bin/nash: error while loading shared libraries: libm.so.6: cannot open shared
object file: N such file or directory
Kernel panic - not syncing: attempting to kill init!"


Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2905.fc7
mkinitrd-6.0.6-1



How reproducible:
every time

Steps to Reproduce:
1.boot any 2.6.19 kernel from rawhide
2.
3.
  
Actual results:
kernel panic that happens on any 2.6.19 kernel.
the error produced when booting kernel-2.6.19-1.2905.fc7
is:
"/bin/nash: error while loading shared libraries: libm.so.6: cannot open shared
object file: N such file or directory
Kernel panic - not syncing: attempting to kill init!"


Expected results:
normal boot


Additional info:
this is a box with a Intel P4 with H/T with one IDE hard drive.
[root@localhost ~]# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      54753340  15245676  36681424  30% /
/dev/hda2               101105     33830     62054  36% /boot
tmpfs                   241304         0    241304   0% /dev/shm 
[root@localhost ~]# fdisk -l

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        2550    20482843+   c  W95 FAT32 (LBA)
/dev/hda2            2551        2563      104422+  83  Linux
/dev/hda3            2564        9729    57560895   8e  Linux LVM
[root@localhost ~]#
Comment 1 Mikko Huhtala 2007-02-07 06:19:53 EST
I also get panic on booting from an IDE drive. This is on a plain old P4 box
from 2001. The kernel version is 2.6.20-1.2922.fc7

Boot ends in panic with the following:

mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempt to kill init!

--

Kernel 2.6.18-1.2798.fc6 boots normally and works.

--

hdparm -I /dev/hda says:

/dev/hda:

ATA device, with non-removable media
        Model Number:       ST380011A                               
        Serial Number:      3JVAATZF            
        Firmware Revision:  3.06    
Standards:
        Used: ATA/ATAPI-6 T13 1410D revision 2 
        Supported: 6 5 4 

--

lspci says:

00:00.0 Host bridge: Intel Corporation 82850 850 (Tehama) Chipset Host Bridge
(MCH) (rev 02)
00:01.0 PCI bridge: Intel Corporation 82850 850 (Tehama) Chipset AGP Bridge (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 04)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 (rev 04)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 04)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus (rev 04)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation NV20 [GeForce3 Ti 500]
(rev a3)
02:02.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
02:03.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
02:04.0 SCSI storage controller: Adaptec AIC-7861 (rev 03)




Comment 2 Mikko Huhtala 2007-02-14 14:18:20 EST
kernel-2.6.20-1.2925.fc7 still panics on boot, with the same messages - "could
not find filesystem '/dev/root' " etc.

Shortly before the panic, the hard drive partitions are listed as sda1, sda2,
sda3 ... Is this as it should be (and is this problem related to the SATA
issues)? The device is an old IDE disk (see specs above). 
Comment 3 Mikko Huhtala 2007-02-14 14:36:56 EST
This is likely a duplicate of #218444
Comment 4 Mikko Huhtala 2007-02-15 18:19:00 EST
Yes! It _boots_.

2.6.20-1.2930.fc7 works for me. My hda of six years is now sda and fstab had to
be changed to use labels, but it works. CD-ROM drive also works, although the
kernel gave some strange messages about it during boot.
Comment 5 Bug Zapper 2008-04-03 14:51:59 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 6 Richard Hally 2008-04-03 23:31:27 EDT
close this bug.
 It is way too old. 15 months and no response from devel just shows the futility
of filing bug in the first place.
 I hope your cleanup efforts lead to better responses.

Note You need to log in before you can comment on or make changes to this bug.