Bug 221814 - unacceptably long delays between switching between fields in composer
unacceptably long delays between switching between fields in composer
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-08 04:09 EST by Matěj Cepl
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 15:50:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2007-01-08 04:09:54 EST
Description of problem:
On a computer with 512MB RAM + 1G swap and 1.3GHz CPU (so hard to say, it is
underpowered) evolution gradually slows down to becoming almost useless --
especially switching between fields can get to minute or more.

Version-Release number of selected component (if applicable):
2.8.0-7.fc6

How reproducible:
gradually always

Steps to Reproduce:
1.use Evolution for some time with couple of accounts (two IMAPs, one local
mails, one Maildirs)
2.it gets slower and slower and slower
3.
  
Actual results:
Evolution becomes unacceptably slow

Expected results:
behavior shouldn't change by the time of use

Additional info:
Probably some memory leak, but how to find it? However, top doesn't show
increased either memory or CPU use.
Comment 1 Matthew Barnes 2007-01-08 05:44:00 EST
Thanks for the bug report.

Can you please clarify what you mean by "switching fields in composer"?  Also,
have you tried disabling some of the accounts you're using in order to try and
isolate the problem to certain mail account types?
Comment 2 Matěj Cepl 2007-01-08 06:21:32 EST
I have switched off everything except of RH IMAP and local mails and the
situation was still the same. Actually, it seems to me that switching other
accounts (IMAP to fastmail.fm and local Maildir folders) didn't make that much
difference.
Comment 3 Matěj Cepl 2007-01-08 06:46:54 EST
switching fields in composer -- Tab between "To", "Cc", "Subject" fields and
body of the text.
Comment 4 Matthew Barnes 2007-10-05 11:49:53 EDT
My apologies that I still have not investigated this one yet.

Can you please re-test with Fedora 8 Test 2 or later?
Comment 5 Matěj Cepl 2007-10-05 15:34:02 EDT
It has been long time ago since I saw it last time. Unfortunately, it might be
still present on RHEL-5 (which I haven't used on regular basis since release of
Fedora 7). Evolution is not as fast as I would like (especially when RH LDAP
automatic address completion comes to play), but now it is reasonably slow,
before that it was really crazy.
Comment 6 Matthew Barnes 2007-10-05 15:50:07 EDT
Okay, thanks for responding.

Since there's not really anything for me to do here I'm going to close this as
WORKSFORME, but feel free to re-open this if you see it again on Fedora 7 or
later.  And also please open a new bug if you see this on RHEL5.

Note You need to log in before you can comment on or make changes to this bug.