Bug 221847 - /tmp/autoXXXXXX remnants littering /tmp
/tmp/autoXXXXXX remnants littering /tmp
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks: 222254
  Show dependency treegraph
 
Reported: 2007-01-08 10:19 EST by Tom London
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-09 09:49:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix typo in var when removing temp directory (310 bytes, patch)
2007-01-08 10:41 EST, Ian Kent
no flags Details | Diff

  None (edit)
Description Tom London 2007-01-08 10:19:31 EST
Description of problem:
/tmp seems to be filled with lots of empty directories apparently from
'mktemp("/tmp/autoXXXXXX"):

[tbl@localhost tmp]$ ls -ld /tmp/auto*
drwx------ 2 root root 4096 Jan  5 09:13 /tmp/auto02XC4F
drwx------ 2 root root 4096 Jan  7 09:38 /tmp/auto0gYYyb
drwx------ 2 root root 4096 Jan  3 06:10 /tmp/auto13kWtO
drwx------ 2 root root 4096 Jan  8 06:45 /tmp/auto2pjCpx
drwx------ 2 root root 4096 Jan  5 06:49 /tmp/auto2WgrWx
drwx------ 2 root root 4096 Jan  6 10:02 /tmp/auto2YBTyZ
drwx------ 2 root root 4096 Jan  7 14:06 /tmp/auto4fe0RR
drwx------ 2 root root 4096 Jan  3 08:49 /tmp/auto6rG03e
drwx------ 2 root root 4096 Jan  5 06:23 /tmp/auto7ZtxBP
drwx------ 2 root root 4096 Jan  4 12:38 /tmp/auto8GWC8k
drwx------ 2 root root 4096 Jan  3 10:18 /tmp/auto9oKw4R
drwx------ 2 root root 4096 Jan  4 06:17 /tmp/auto9X67Db
drwx------ 2 root root 4096 Jan  8 07:01 /tmp/autoaLEpqx
drwx------ 2 root root 4096 Jan  6 16:13 /tmp/autoApa4r6
drwx------ 2 root root 4096 Jan  5 09:13 /tmp/autoByEQH9
drwx------ 2 root root 4096 Jan  3 10:18 /tmp/autocJMEd1
drwx------ 2 root root 4096 Jan  3 06:50 /tmp/autockPwUJ
drwx------ 2 root root 4096 Jan  8 07:01 /tmp/autodaCVIj
drwx------ 2 root root 4096 Jan  2 09:10 /tmp/autodGUaU4
drwx------ 2 root root 4096 Jan  7 09:38 /tmp/autoGSEWTp
drwx------ 2 root root 4096 Jan  3 15:25 /tmp/autoHBRg0J
drwx------ 2 root root 4096 Jan  3 06:50 /tmp/autoHTbVH0
drwx------ 2 root root 4096 Jan  6 10:02 /tmp/autoiGWphN
drwx------ 2 root root 4096 Jan  2 06:16 /tmp/autoII6q8V
drwx------ 2 root root 4096 Jan  7 14:06 /tmp/autoJ7pau3
drwx------ 2 root root 4096 Jan  8 06:20 /tmp/autoK3NRQU
drwx------ 2 root root 4096 Jan  5 06:23 /tmp/autok8mRgO
drwx------ 2 root root 4096 Jan  4 12:38 /tmp/autoLqFif3
drwx------ 2 root root 4096 Jan  3 08:49 /tmp/autonC7yVn
drwx------ 2 root root 4096 Jan  6 16:13 /tmp/autoO2dTp4
drwx------ 2 root root 4096 Jan  3 06:39 /tmp/autoP1UucE
drwx------ 2 root root 4096 Jan  4 06:17 /tmp/autopfA3td
drwx------ 2 root root 4096 Jan  3 15:25 /tmp/autopuxDUP
drwx------ 2 root root 4096 Jan  8 06:45 /tmp/autopXq29S
drwx------ 2 root root 4096 Jan  7 11:00 /tmp/autoQAyN0h
drwx------ 2 root root 4096 Jan  7 10:51 /tmp/autorXo6NM
drwx------ 2 root root 4096 Jan  4 11:22 /tmp/autoSyzxYp
drwx------ 2 root root 4096 Jan  8 06:20 /tmp/autoszrsU1
drwx------ 2 root root 4096 Jan  2 06:16 /tmp/autoTEouFB
drwx------ 2 root root 4096 Jan  6 09:19 /tmp/autoTn3JC3
drwx------ 2 root root 4096 Jan  4 11:22 /tmp/autoUnOJja
drwx------ 2 root root 4096 Jan  7 11:00 /tmp/autoUuvWd7
drwx------ 2 root root 4096 Jan  6 09:19 /tmp/autovX7MA7
drwx------ 2 root root 4096 Jan  3 06:39 /tmp/autowfUdH8
drwx------ 2 root root 4096 Jan  3 06:10 /tmp/autowr4uHs
drwx------ 2 root root 4096 Jan  5 06:49 /tmp/autoWZFjij
drwx------ 2 root root 4096 Jan  2 09:10 /tmp/autox4TNfk
drwx------ 2 root root 4096 Jan  7 10:51 /tmp/autozjesEq
[tbl@localhost tmp]$ 

[root@localhost sbin]# strings automount | grep tmp
/tmp/autoXXXXXX
[root@localhost sbin]# 

Possible that /usr/sbin/automount is not removing?


Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc2.41

How reproducible:
every time.....

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ian Kent 2007-01-08 10:31:24 EST
(In reply to comment #0)
> Description of problem:
> /tmp seems to be filled with lots of empty directories apparently from
> 'mktemp("/tmp/autoXXXXXX"):

Yes.
I have noticed that.
I had a go at fixing it but I must have not got
it right.

I'm about to look again.
Sorry.

Ian
Comment 2 Ian Kent 2007-01-08 10:41:22 EST
Created attachment 145063 [details]
Fix typo in var when removing temp directory

Don't know how I missed this, twice even.
Could you verify this patch fixes the problem please.

Ian
Comment 3 Tom London 2007-01-08 12:36:44 EST
Yes, appears so.

I downloaded source rpm, installed, did a 'rpmbuild -bp', manually applied the
above patch, and did a 'rpmbuild -bc --short-circuit'.  Installed both automount
and mount_bind.so, cleaned out /tmp/auto* and did a 'service autofs restart'.

No /tmp/autofs* files in /tmp!
Comment 4 Ian Kent 2007-01-08 12:56:09 EST
(In reply to comment #3)
> Yes, appears so.
> 
> I downloaded source rpm, installed, did a 'rpmbuild -bp', manually applied the
> above patch, and did a 'rpmbuild -bc --short-circuit'.  Installed both automount
> and mount_bind.so, cleaned out /tmp/auto* and did a 'service autofs restart'.
> 
> No /tmp/autofs* files in /tmp!

Great I'll commit it and push it out.

Ian
Comment 5 Tom London 2007-01-09 09:49:46 EST
Installed, rebooted..... No /tmp/auto* files.

Thanks!

Closing....

Note You need to log in before you can comment on or make changes to this bug.