Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
DescriptionVladimír Sedmík
2023-06-29 13:58:42 UTC
Description of problem:
During verification of BZ#1944710 I tried to change lifecycle environment of a host through bulk actions on the Content Hosts page. The first issue is that we are still able to assign a LCE not present on the content source (like external capsule), the second issue is that it fails with
undefined method `content_view=' for #<Katello::Host::ContentFacet:0x00007f77416c1528>
Version-Release number of selected component (if applicable):
6.14.0 snap 4
How reproducible:
always
Steps to Reproduce:
1. Register a host through external capsule where only some LCEs are synced.
2. Go to Content Hosts -> select host -> Select Action -> Change Lifecycle Environment
3. In the "Content Host Bulk Content" modal select a LCE, CV, click Assign, confirm Yes
Actual results:
Fails with 'undefined method' error
Expected results:
1. no 'undefined methor' error
2. I shouldn't be able to pick LCE not present on the content source, or at least I should get meaningful error message
The
undefined method `content_view=' for #<Katello::Host::ContentFacet:0x00007f77416c1528>
should be solved by https://bugzilla.redhat.com/show_bug.cgi?id=2215081.
However, we should still fix the UI issue in this BZ.
Thinking some more about this, when selecting multiple hosts there's no sane way to scope the selections to only the content source(s) of the selected hosts. So I'm thinking for bulk actions we may just want to close this BZ (when https://bugzilla.redhat.com/show_bug.cgi?id=2218528#c3 is confirmed) and allow it to fall back to the API error.