Bug 221883 - 'hardlink -h' generates SEGFAULT
'hardlink -h' generates SEGFAULT
Status: CLOSED DUPLICATE of bug 197789
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-utils (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-08 13:14 EST by Andreas Piesk
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-16 14:07:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fixing segfault (264 bytes, patch)
2007-01-08 13:14 EST, Andreas Piesk
no flags Details | Diff
Patch to fix segfault and actually implement -h flag. (4.13 KB, patch)
2007-03-16 13:34 EDT, Jarod Wilson
no flags Details | Diff

  None (edit)
Description Andreas Piesk 2007-01-08 13:14:22 EST
Description of problem:

executing 'hardlink -h' produces coredump

Version-Release number of selected component (if applicable):

kernel-utils-2.4-13.1.83.src.rpm
Comment 1 Andreas Piesk 2007-01-08 13:14:23 EST
Created attachment 145091 [details]
patch fixing segfault
Comment 2 Jarod Wilson 2007-03-16 13:32:52 EDT
Hrm, we fixed this a while ago, but somehow never got the fix into RHEL4...
Would actually like to go beyond just the one-line patch to actually implement
the -h flag too.
Comment 3 Jarod Wilson 2007-03-16 13:34:45 EDT
Created attachment 150259 [details]
Patch to fix segfault and actually implement -h flag.
Comment 4 Jarod Wilson 2007-03-16 13:38:01 EDT
*** Bug 219609 has been marked as a duplicate of this bug. ***
Comment 5 Radek Bíba 2007-03-16 14:07:19 EDT
Speaking of duplicates...

*** This bug has been marked as a duplicate of 197789 ***

Note You need to log in before you can comment on or make changes to this bug.