Bug 221894 - Add BuildRequires: doxygen to rpm specfile
Add BuildRequires: doxygen to rpm specfile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-08 14:33 EST by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 08:13:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to conditionally BuildRequire doxygen (824 bytes, patch)
2007-01-09 11:44 EST, Dave Malcolm
no flags Details | Diff

  None (edit)
Description Dave Malcolm 2007-01-08 14:33:08 EST
Description of problem:
I'm looking for detailed documentation on the RPM API

http://fedora.redhat.com/docs/drafts/rpm-guide-en/ch16s07.html
says:
"The RPM bindings for Python are documented along with the C programming API. On
a Red Hat Linux system, look in the file
/usr/share/doc/rpm-devel-4.1/apidocs/html/group__python.html to see the start of
the Python-specific documentation."

However, on my FC6 box, I don't have any content in:
/usr/share/doc/rpm-devel-4.4.2/apidocs
(with rpm-devel-4.4.2-32, and they're not listed in rpm -ql)

They're present on my RHEL3 box with rpm-devel-4.2.3-24_nonptl in 
/usr/share/doc/rpm-devel-4.2.3/apidocs/html/

Did they get deleted, moved to a different package, etc?  What's the canonical
online location for these docs?  I don't see them at rpm.org.

Thanks
Comment 1 Dave Malcolm 2007-01-08 14:53:24 EST
I found a generated copy online here:
http://wraptastic.org/apidocs/html/index.html
Comment 2 Dave Malcolm 2007-01-08 14:59:23 EST
(specifically, is rpmExpand exposed directly anywhere by the python bindings?  I
couldn't find it, only addMacro and delMacro)
Comment 3 Jeff Johnson 2007-01-09 08:40:28 EST
Yep, apidocs are not generated if doxygen is not installed in build tree.

Note that the URL in #1 no longer has anything to do with your rpm-4.4.2, fork you!

Yep, rpmExpand() was never added to rpm-python even after several suggestions from me.
The script kiddie's consensus opinion was that applications that use rpm-python should never ever have
to know about rpm confuguration elemens. Not my call, mon.
Comment 4 Dave Malcolm 2007-01-09 11:44:03 EST
Created attachment 145177 [details]
Patch to conditionally BuildRequire doxygen 

Attached patch is for devel (i.e. F7):
adds a BuildRequires on doxygen; conditionalised to ease people wanting to
strip down the build.  
No Changelog entry.
Comment 5 Dave Malcolm 2007-01-09 12:06:43 EST
Changing summary to "Add BuildRequires: doxygen to rpm specfile", and moving to
devel, since it still affects rpm-devel-4.4.2-38.fc7.i386.rpm

pnasrat: OK to apply this and rebuild in devel (with a changelog)?
Comment 6 Panu Matilainen 2007-06-27 08:13:45 EDT
Having separate htmldocs conditional doesn't make much sense IMO because if the
html docs aren't generated, apidocs is empty.

Current rawhide unconditionally buildrequires doxygen so the issue is fixed, but
if you want to make it conditional on %{with_apidocs} I don't mind.
Comment 7 Panu Matilainen 2007-06-27 08:20:57 EDT
Oh and as to comments #2 and #3, I'm going to add evalMacro() (or whatever you
want to call it) to the python bindings. Always mystified me why there isn't
such a method.

Note You need to log in before you can comment on or make changes to this bug.