Bug 221905 - Add SMD5 password support
Add SMD5 password support
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Server - Plugins (Show other bugs)
1.0.2
All Linux
high Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
Depends On:
Blocks: 434914 389_1.3.0 389_1.2.4
  Show dependency treegraph
 
Reported: 2007-01-08 15:34 EST by Josh Kelley
Modified: 2015-12-07 12:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:07:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch adding SMD5 support (7.32 KB, patch)
2007-01-08 15:34 EST, Josh Kelley
no flags Details | Diff
Proposed Patch (18.12 KB, patch)
2009-10-26 16:09 EDT, Nathan Kinder
no flags Details | Diff

  None (edit)
Description Josh Kelley 2007-01-08 15:34:30 EST
Description of problem:

Fedora Directory Server lacks SMD5 (Salted MD5) password support.  This makes
migration from OpenLDAP harder, since OpenLDAP may default to SMD5.

Version-Release number of selected component (if applicable):
1.0.2

How reproducible:
Always

Steps to Reproduce:
1. Import OpenLDAP data with SMD5-hashed passwords.

Actual results:
Account passwords are unrecognized, SMD5 is not an option for new passwords.

Expected results:
Account passwords work, SMD5 is an option for new passwords.

Additional info:
We've been running the attached patch for a while to add SMD5 support on our
install.  It's still rough, but I can clean it up if it's something you can use.
Comment 1 Josh Kelley 2007-01-08 15:34:31 EST
Created attachment 145101 [details]
Patch adding SMD5 support
Comment 2 Nathan Kinder 2009-10-26 16:09:56 EDT
Created attachment 366151 [details]
Proposed Patch
Comment 3 Nathan Kinder 2009-10-26 18:24:05 EDT
Pushed patch from attachment #2 [details] to master.

Counting objects: 36, done.
Delta compression using 2 threads.
Compressing objects: 100% (19/19), done.
Writing objects: 100% (20/20), 5.26 KiB, done.
Total 20 (delta 15), reused 0 (delta 0)
To ssh://git.fedorahosted.org/git/389/ds.git
   41fa124..333c980  master -> master
Comment 4 Jenny Galipeau 2010-05-13 10:28:02 EDT
verified - SMD5 (Salted MD5) password support has been added and is being tested via automated acceptance and stress testing.

Note You need to log in before you can comment on or make changes to this bug.