Bug 221974 - hald needs to not die when the cpu does not support cpuspeed
hald needs to not die when the cpu does not support cpuspeed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
: Reopened
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-01-09 08:47 EST by Dennis Gilmore
Modified: 2013-03-05 22:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 14:01:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of hald --verbose=yes --daemon=no (96.71 KB, text/plain)
2007-09-29 18:57 EDT, Dennis Gilmore
no flags Details

  None (edit)
Description Dennis Gilmore 2007-01-09 08:47:00 EST
Description of problem:
hald dies if the cpu does not support cpu speed after running 
hald-addon-cpufreq

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. hald --no-daemon
2.
3.
  
Actual results:
hald-addon-cpufreq
07:43:23.614 [W] addon-cpufreq.c:1178: CPUFreq not supported. Exiting...


Expected results:
hald to run

Additional info:
Comment 1 David Zeuthen 2007-04-02 19:28:21 EDT
Is this still happening?
Comment 2 Jarod Wilson 2007-04-03 12:57:46 EDT
Appears this is still happening. I've got a ppc64 box that doesn't support freq
scaling running current rawhide, and the hal daemon dies a miserable death on
it, with error messages related to frequency scaling.
Comment 3 David Zeuthen 2007-04-03 15:25:23 EDT
Can you attach the output of hald? Please see the hald(8) manpage for details on
how to do that. Thanks.
Comment 4 Jarod Wilson 2007-04-25 17:01:07 EDT
Seems to be working just fine now. Dennis, can you reopen if you're still seeing
problems?
Comment 5 Dennis Gilmore 2007-09-29 18:57:46 EDT
Created attachment 211471 [details]
output of hald --verbose=yes --daemon=no
Comment 6 Dennis Gilmore 2007-09-29 18:58:24 EDT
this is still happening with hal-0.5.9-8
Comment 7 David Zeuthen 2007-10-11 14:01:03 EDT
Appears, according to comment 4, that the hal in Rawhide works which is what
this bug is about. Dennis can you clone this bug for Fedora 7? Rawhide moved on
from hal 0.5.9 some time ago...

Note You need to log in before you can comment on or make changes to this bug.