Bug 221980 - libao.i386 missing on x86_64
libao.i386 missing on x86_64
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libao (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-09 09:16 EST by Florian La Roche
Modified: 2013-04-15 04:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0101
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 16:17:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2007-01-09 09:16:18 EST
Description of problem:

On x86_64 we have both -devel rpms for x86_64 and i386, but the
libao.i386 rpm is missing.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Dennis Gregorovic 2007-01-10 13:52:08 EST
libao-devel doesn't depend on libao, which is why it doesn't get pulled in.
 If libao.i386 is really needed, then having libao-devel depend on it would
be the preferred solution.
Comment 3 Matthias Clasen 2007-01-11 14:52:41 EST
Trivial fix
Comment 4 Behdad Esfahbod 2007-01-11 15:51:16 EST
It does depend on libao = %{version} AFAICS.  I can change that to libao =
%{version}-%{release}.  Not sure if that makes much difference here.
Comment 9 Florian La Roche 2007-08-18 03:43:06 EDT
If the requires for the package is already in, then the rpm
itself is ok. Question is what benefit the libao-devel.i386 should
be if the libao.i386 is missing and you cannot link against it.

regards,

Florian La Roche

Comment 10 Behdad Esfahbod 2007-11-28 06:03:25 EST
So, the cause of this issue is that libao suppresses automatic dependency generator:

%define _use_internal_dependency_generator 0
%define __find_requires %{SOURCE1}

The reason it does that is to avoid requiring esd, artsd, audiofile, and asound.
 SOURCE1 is:

#!/bin/sh

filelist=`sed "s/['\"]/\\\&/g"`

{ echo $filelist | tr [:blank:] \\n | /usr/lib/rpm/find-requires | \
        grep -v artsc | grep -v esd | grep -v audiofile | grep -v asound
} | sort -u


I don't know enough RPM to tell what SOURCE1 should be doing that it isn't. :(
Comment 11 Dennis Gregorovic 2007-11-28 16:11:14 EST
Bill,

Do you have a suggestion for how this package can be tweaked such that libao
properly depends on libao-devel?
Comment 12 Bill Nottingham 2007-11-28 16:43:14 EST
A simple:

%ifarch ia64 x86_64 s390x ppc64
Requires: libao.so.<whatever>()(64bit)
%else
Requires: libao.so.<whatever>
%endif

should work.
Comment 13 Behdad Esfahbod 2007-12-17 14:52:43 EST
Built libao-0.8.6-6.
Can someone test this please before I go through the errata process?  Thanks.
Comment 14 Dennis Gregorovic 2007-12-17 16:24:58 EST
I've tagged the build so that it should be picked up in tomorrow's nightly, and
we can see if that fixes the problem.
Comment 22 errata-xmlrpc 2008-02-13 16:17:19 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0101.html

Note You need to log in before you can comment on or make changes to this bug.